Find the answer to your Linux question:
Results 1 to 4 of 4
My mouse wheel doesn't work. I added Option "ZAxisMapping" "4 5" to xorg.conf, and tried both /dev/mouse and /dev/psaux Restarted X both times (ofcourse) but still no result. I've got ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2005
    Posts
    70

    Mouse scroll doesn't work


    My mouse wheel doesn't work.

    I added
    Option "ZAxisMapping" "4 5"

    to xorg.conf, and tried both /dev/mouse and /dev/psaux

    Restarted X both times (ofcourse)
    but still no result. I've got fuzzy image about adding another thing to xorg / xfree86 config what made my mouse working under SuSe, but don't remember it anymore..

    Thx for advance.

    ps. Slackware 10, and mouse is old Logitech.


    Got t working after noticed couple of lines between commented ones.

  2. #2
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    My Logitech scroll mouse works well under Fedora Core 1:
    Code:
    Section "InputDevice"
            Identifier  "Mouse0"
            Driver      "mouse"
            Option      "Protocol" "IMPS/2"
            Option      "Device" "/dev/psaux"
            Option      "ZAxisMapping" "4 5"
            Option      "Emulate3Buttons" "no"
    EndSection
    I hope that helps.
    /IMHO
    //got nothin'
    ///this use to look better

  3. #3
    Just Joined!
    Join Date
    Nov 2006
    Location
    Bangalore, India
    Posts
    1

    Smile Mouse scroller wasn't working - fixed

    System - Fedora Core 6

    Previously Mouse wasn't working at all.

    I copied the following entries from my friend's computer to xorg.conf

    Section "Input Device"
    Identifier "Mouse0"
    Driver "mouse"
    Option "Protocol" "auto"
    Option "Device" "/dev/input/mice"
    #Option "ZAxisMapping" "4567"
    Option "ZAxisMapping" "4 5"
    Option "Emulate3Buttons" "yes"
    EndSection

    At this point the mouse started working but stopped again after sometime. And then I deleted rhgb quiet from grub.conf and it started working but without the scroller.

    Then I changed the following entry to

    Option "ZAxisMapping" "4 5"

    Now I'm all set. Thank you for posting the "ZAxisMapping" "4 5"

  4. #4
    Just Joined!
    Join Date
    Nov 2006
    Location
    Massachusetts
    Posts
    4

    ZAxisMapping not helping

    OK, I've read tons of posts on how to get a scroll wheel working... ...but they haven't helped me. I have a run of the mill HP optical PS/2 scroll mouse. Here is the section from my xorg.conf which doesn't work. ANY help is appreciated.

    Section "InputDevice"
    Driver "mouse"
    Identifier "Mouse[1]"
    Option "Buttons" "5"
    Option "Device" "/dev/input/mice"
    Option "Name" "PS/2 Generic Mouse"
    Option "Protocol" "IMPS/2"
    Option "Vendor" "Sysp"
    Option "ZAxisMapping" "4 5"
    EndSection

    BTW: Does anyone know what the "Vendor" "Sysp" option is for?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •