Find the answer to your Linux question:
Results 1 to 3 of 3
Hard drive Maxtor 6E040L0 40Gb I had this drive working at full capacity with Fedora Core 1 with Maxtor's "MaxBlast" dynamic disk overlay installed. Though I don't recall details, after ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817

    Disk Geometry Problem


    Hard drive Maxtor 6E040L0 40Gb
    I had this drive working at full capacity with Fedora Core 1 with Maxtor's "MaxBlast" dynamic disk overlay installed. Though I don't recall details, after using the system a short time, I somehow over-wrote the DDO and then lost full capacity. I have since read the "Large Disk HOWTO" and it says repeatedly that kluges like DDO are not required with modern kernels (post 2.2). I have recently installed the drive into another machine and am trying to get the full 40Gb capacity by the most efficient and robust means available, given my hardware. The computer is an Abit PX-5 with Award BIOS dated 1997.

    I've tried all combinations of BIOS settings and have settled on turning off BIOS detection, which Linux doesn't seem to mind. I have tried feeding the drive geometry to the kernel at boot, with no apparent effect. And I have tried setting the geometry in /proc/ide/hda/settings per the directions of the HOWTO. The geometry that worked with FC1 was 4998/255/63. Even though I can change it to that geometry in fdisk (expert menu) or
    with
    Code:
    # echo bios_cyl:4998 bios_head:255 bios_sect:63 > /proc/.../settings
    when I run fdisk -l, it still reports 21.1Gb.

    As suggested in the HOWTO, I installed the capacity clipping jumper, making it a 2.1Gb drive, and then I ran the suggested setmax program with the following results:
    Code:
    # setmax -d 0 /dev/hda
    Using device /dev/hda
    setting delta=0
    nativemax=80293427 (0x4c92d7f)
    lba capacity: 80293428 sectors (41110142976 bytes)
    It's a 40Gb drive! After running setmax and setting the geometry to 4998/255/63 in /proc/.../settings, fdisk -l continues to report the clipped 2.1Gb capacity and after changing the geometry in fdisk, running mkfs is not possible: "unable to seek on .../hda".

    Prior to installing the clipping jumper and prior to running setmax, when I changed the geometry in /proc/.../settings and in fdisk, running mkfs resulted in an error (scrolling screenful, hard boot required).

    All of the above (except for the Fedora Core 1 part) was done with a Gentoo live CD with the 2.4 kernel.
    /IMHO
    //got nothin'
    ///this use to look better

  2. #2
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    **Bump**

    Is there no option but to use MaxBlast? I'm afraid I won't be able to use it as a boot disk, because I think Grub will over-write the dynamic disk overlay.
    /IMHO
    //got nothin'
    ///this use to look better

  3. #3
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    Is there no option but to use MaxBlast? I'm afraid I won't be able to use it as a boot disk, because I think Grub will over-write the dynamic disk overlay.
    Having no better solution, I found a kluge work-around. But to clear up this point, Grub does not over-write the dynamic disk overlay.
    /IMHO
    //got nothin'
    ///this use to look better

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •