Find the answer to your Linux question:
Results 1 to 9 of 9
Hi, I would be interested to know whether anyone has experienced problems with installing Linux on Intels latest generation of the Pentium M processor, code-named "sonoma"? In particular, I would ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Posts
    1

    linux on the sonoma centrino platform?


    Hi,

    I would be interested to know whether anyone has experienced problems with
    installing Linux on Intels latest generation of the Pentium M processor, code-named "sonoma"?
    In particular, I would be interested to hear about linux installations on the new Dell Latitude notebooks, D810 and D610. Any general advice on this issue yet?

    TIA,

    Peter

  2. #2
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    Hi,
    There should be no problems installing linux on any kind of PC. It is just that older versions of linux did not have support for laptop LCD's. As long as you use a modern distro e.g. mandrake 10, then you should have no problem with installing linux.

    I am dual booting Mandrake 10.1 and Win XP Pro on my Toshiba Satellite P30. So far there has been no problems.

  3. #3
    Just Joined!
    Join Date
    Mar 2005
    Posts
    1

    Plenty problems

    I have a new Asus TM8103.

    Tried installing Gentoo but despite mucking about with kernel builds could not get it to boot (although the universal boot CD does boot).

    Knoppix live CD will not boot.

    Given up and gone to FreeBSD.

  4. $spacer_open
    $spacer_close
  5. #4
    jpb
    jpb is offline
    Just Joined!
    Join Date
    Apr 2005
    Posts
    4
    I experienced many issues with a Dell Latitude D810.

    First , good new : a very old Mandrake9.2, with an older 2.4 kernel, installs OK from the CD, and run almost OK. (I did very few check with this old release).

    With a standard Mandrake 10.1 distro, you can boot from the CD1 with a "alt1" option to run the install process under a 2.4 kernel.
    The standard Mandrake 10.1 install process is setting up three kernels. The only one that could boot from the HD was the 2.4 one.
    2.6.8 kernel hangs during the boot process. It looks as it was unable to reach the hard disk IDE/ATA.
    (The boot manager is Lilo. It probably reads the disk by BIOS functions; But the actual Linux kernel wants use its own drivers).

    That seems from Sonoma ICH6M chip, that comes with an (unused on the DELL D810) built in SATA controller.
    Old 2.4 kernels ignores such a "new" controller and work with ATA HD and DVD (but without DMA )
    Recent 2.6 seeks probably the HD behind the SATA controller; where it is NOT!

    BIOS A01 from Dell seems provide no mean to disable the unused SATA controller.

  6. #5
    Just Joined!
    Join Date
    Mar 2005
    Posts
    6

    yeah, doesn't work

    same issues here with the HD!

    Doesn't work with SATA built into the kernel - just hangs with a black screen

    Doesn't work PROPERLY with the IDE controller as it won't enable DMA properly.

    Damned if you do and damned if you don't !!

    Any ideas?

  7. #6
    jpb
    jpb is offline
    Just Joined!
    Join Date
    Apr 2005
    Posts
    4

    News about damned Intel Sonoma chipset ...

    To enmane : HD (on IDE0) and CD / DVD (on IDE1) are in the same boat ...

    2 news since my last post :

    First :my tries with Fedora Core 3 ...

    Second : while "googling", i found a post from a guy who wrote that he succeeded in installing Mandrake 10.2 RC2, by keying a "magic formula" to force the insmod of ata_piix IDE driver
    Unfortunatly the post did not contain the magic formula...
    Damned . I have lost the URL...

    _____ My own story now:
    I tried install Fedora Core 3 : It runs OK "out of the (downloaded ) box"..
    But, when booting (OK) from HD, two little diags said that IDE0 ports are already occupied; and that it is stopping its IDE probing...

    The Fedora C3 Linux worked OK, first try! Well! !!
    It recognized automatically the Broadcom built-in Eternet controller, and the Internet connection worked fine (behind a home DHCP router): Very Well!
    With the generic video driver , i could not choose the 1680x1050 definition for my screen; but a 1400x1050 worked quite good. Well!

    I was unable to install the Wifi IPW2200 driver, but i did few tries...

    But... (as there remains a but (If it is not a "but", it's a feature ? ) :
    hdparm returns non sensible information about HD.
    I presume that all the discs access were done thru the BIOS and not through the hardware..., So hdparm failed on each attempt to access the disk.

    Continuation next week ?

  8. #7
    Just Joined!
    Join Date
    Mar 2005
    Posts
    6

    Kbuntu

    I downloaded kbuntu over the weekend and it seemed to recognize EVERYTHING including
    * wireless
    * ati card and drivers
    * 1920x1600 lcd
    * speedstepping properly configured and working
    * HD "seemed" to work.

    It booted and worked nice but I couldn't do any testing on the HD since it appeared to install SATA drivers and there are some "root" configuration/control issues that I couldn't get past. I didn't know how to "su" as root since I didn't have the correct password and there was none stated. It noted the partitions correctly but I couldn't mount them because they weren't in fstab (needed root permissions to edit) and I couldn't force a mount (needed root permissions).
    Kbuntu has it where it counts in my book! It is a little thin in the apps but for a distro to work THIS WELL with a brand new laptop and have all of the essentials up and working - I WAS FLOORED.

  9. #8
    jpb
    jpb is offline
    Just Joined!
    Join Date
    Apr 2005
    Posts
    4
    Thank you , enmane, for your very useful help:
    First, I dowloaded Ubuntu 5.04 LIVE : My first checks on the Dell D810 were pretty good. All the hardware seemed well managed.
    So, I decide to download Kubuntu 5.04 install that comes with KDE. ...

  10. #9
    jpb
    jpb is offline
    Just Joined!
    Join Date
    Apr 2005
    Posts
    4
    Complement about the "root" password : I just check the "LIVE" CD, for compatibility check only.
    This special configuration comes with 2 accounts : one is ubuntu (password ubuntu? but no matter : It doesn't ask for a password at startup.)
    The other is, obviously, "root"; I did not guess the password, but a "SU Xterm" is installed in the Gnome application launcher menu. So you can run a root shell. Under this root shell, I succeeded in mounting the HD partitions that I have created for Mandrake.

    The Ubuntu kernel is a recent Debian (may be I could remember for something like : 2.6.10.5): The ATA disk , behind SATA controller is recognized as a /dev/sda unit. (Mandrake 2.4 recognized it as an ATA /dev/hda; and Mandrake 2.6.8 just refused to discover the disk...). My /dev/sda* partitions could be mounted OK on the Ubuntu "Live" files hierachy!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •