Find the answer to your Linux question:
Results 1 to 4 of 4
Hi everyone, I've been trying to beat this all afternoon, googling all over the place... I need some help now. I'm running a gentoo with 3 usb devices; my wireless ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Posts
    3

    USB mouse loaded but no /dev/input/mice output


    Hi everyone,

    I've been trying to beat this all afternoon, googling all over the place... I need some help now.

    I'm running a gentoo with 3 usb devices; my wireless intellimouse explorer, a pen drive and a casio ex-s100 digital camera.

    Until yesterday, only the mouse worked, I wasn't getting any dmesg / log feedback for other devices plugging in (I had never tried to ude them before). I figured out it was because I had compiled the wrong Host Controller in the kernel. I had UHCI Alternate and I changed to OHCI because I have a SiS chipset.
    As I did that I aslo compiled Preliminary USB Device Filesystem, USB Full HID support and Input Core Mouse Support.

    Now that I have OHCI, all my devices show up in dmesg and the logs when I plug/unplug them. I've tested the pendrive and the camera and they work fine.

    My mouse though, also shows up in dmesg and the kernel log but it doesn't work with Xorg anymore (it did back when I still had UHCI Alternate compiled in the kernel).
    I believe the device is supposed to be /dev/input/mice, but it doesn't output anything when I cat /dev/input/mice and wiggle the mouse, neither with /dev/mouse. It's completely dead in Xorg and I've runned out of ideas on what to try.

    Any tips would be gratly appreciated !

    Here are some of my outputs:

    extract of cat /proc/bus/usb/devices:
    I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
    E: Ad=81(I) Atr=03(Int.) MxPS= 2 Ivl=255ms
    T: Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#= 2 Spd=1.5 MxCh= 0
    D: Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
    P: Vendor=045e ProdID=0059 Rev= 0.16
    S: Manufacturer=Microsoft
    S: Product=Microsoft Wireless Intellimouse Explorer® 1.0A

    /var/log/kernel/current when I unplug/plug the mouse:
    Feb 14 20:17:57 [kernel] usb.c: USB disconnect on device 00:03.0-1 address 2
    Feb 14 20:18:03 [kernel] hub.c: new USB device 00:03.0-1, assigned address 3
    Feb 14 20:18:03 [kernel] : USB HID v1.10 Mouse [Microsoft Microsoft Wireless Intellimouse Explorer® 1.0A] on usb1:3.0

    extract of dmesg:
    hub.c: new USB device 00:03.0-1, assigned address 2
    : USB HID v1.10 Mouse [Microsoft Microsoft Wireless Intellimouse Explorer® 1.0A] on usb1:2.0
    reiserfs: checking transaction log (device ide0(3,4)) ...
    for (ide0(3,4))
    ide0(3,4):Using r5 hash to sort names
    VFS: Mounted root (reiserfs filesystem) readonly.
    Mounted devfs on /dev
    Freeing unused kernel memory: 124k freed
    hub.c: new USB device 00:03.1-3, assigned address 2
    hub.c: USB hub found
    hub.c: 2 ports detected

    the beginning of my xorg.conf:
    Section "ServerLayout"
    Identifier "X.org Configured"
    Screen 0 "Screen0" 0 0
    InputDevice "Mouse0" "CorePointer"
    InputDevice "Keyboard0" "CoreKeyboard"
    EndSection

    Section "Files"
    RgbPath "/usr/X11R6/lib/X11/rgb"
    ModulePath "/usr/X11R6/lib/modules"
    FontPath "/usr/share/fonts/misc/"
    FontPath "/usr/share/fonts/TTF/"
    FontPath "/usr/share/fonts/Speedo/"
    FontPath "/usr/share/fonts/Type1/"
    FontPath "/usr/share/fonts/CID/"
    FontPath "/usr/share/fonts/75dpi/"
    FontPath "/usr/share/fonts/100dpi/"
    EndSection

    Section "Module"
    Load "record"
    Load "extmod"
    Load "dbe"
    Load "glx"
    Load "xtrap"
    Load "freetype"
    Load "type1"
    Load "speedo"
    EndSection

    Section "InputDevice"
    Identifier "Keyboard0"
    Driver "keyboard"
    EndSection

    Section "InputDevice"
    Identifier "Mouse0"
    Driver "mouse"
    Option "Protocol" "IMPS/2"
    Option "Device" "/dev/input/mice"
    # Option "Buttons" "7"
    # Option "ZAxisMapping" "6 7"
    EndSection

    Some of the Output of my Xorg server:
    (II) Initializing extension GLX
    (**) Option "Protocol" "IMPS/2"
    (**) Mouse0: Device: "/dev/input/mice"
    (**) Mouse0: Protocol: "IMPS/2"
    (**) Option "CorePointer"
    (**) Mouse0: Core Pointer
    (**) Option "Device" "/dev/input/mice"
    (==) Mouse0: Emulate3Buttons, Emulate3Timeout: 50
    (==) Mouse0: Buttons: 3
    (**) Mouse0: SmartScroll: 1
    (II) Keyboard "Keyboard0" handled by legacy driver
    (II) XINPUT: Adding extended input device "Mouse0" (type: MOUSE)
    (II) XINPUT: Adding extended input device "NVIDIA Event Handler" (type: Other)
    (II) Mouse0: ps2EnableDataReporting: succeeded
    Could not init font path element /usr/share/fonts/CID/, removing from list!
    GetModeLine - scrn: 0 clock: 108000
    GetModeLine - hdsp: 1280 hbeg: 1328 hend: 1440 httl: 1688
    vdsp: 1024 vbeg: 1025 vend: 1028 vttl: 1066 flags: 5

    f1x root # ls -l /dev/input/
    total 0
    crw-r--r-- 1 root root 13, 63 Jan 1 1970 mice

    As I said, /dev/input/mice and /dev/mouse stay completely silent on 'cat'.
    If you need anything more, let me know.

    Any thoughts ?

    Thanks

  2. #2
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    Are you sure that you have the 'usbmouse' module either loaded or built into your kernel?
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  3. #3
    Just Joined!
    Join Date
    Feb 2005
    Posts
    3
    I don't know... which one is it as I said I compiled OHCI, USB HID Support, USB Devfs and Input Core USB mouse all in the kernel.

    Insn't that enough ?

  4. #4
    Just Joined!
    Join Date
    Feb 2005
    Posts
    3
    Well I've narrowed it down a little bit;

    The usb mouse works great on /dev/mouse (which links to /dev/psaux) WITHOUT any usb controller support loaded (neither in the kernel or as module).

    When I load OHCI as module for example, everything looks good in dmesg and the kernel log but I can't get the mouse to work.

    /dev/input/mice stays silent, so does /dev/mouse.

    What other Device might I use for my usb mouse ? Or how do I find out what the right one is ?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •