Find the answer to your Linux question:
Results 1 to 5 of 5
My computer has two hard drives, one 80gig with windows xp and a 20gig with SUSE 9.2 installed on it. I also have a DVD drive and a CD burner. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Posts
    5

    Trouble with PCI IDE card


    My computer has two hard drives, one 80gig with windows xp and a 20gig with SUSE 9.2 installed on it. I also have a DVD drive and a CD burner. I got a new 200gig hdd for my xbox so i decided that i should take the old, 80gig, hdd and put it in my computer. It was then that I realized that I was going to have to purchess *something* to be able to have all 5 IDE devices running at one time.

    So i drove down to my local CompUSA to try to buy a splitter cable or something to solve my problem. Upon my arrival the sales representative informed me that it would not be this simple. He sold me a CompUSA brand PCI card that I could just insert into an empty slot and plug up to four more IDE devices into that card.

    The included software cd contained drivers for windows, and windows only (typical). I was able to install the software, format the drive for windows, and use it normally with windows xp. With xp, once the card was installed, it automatically saw the new drive. I was hoping that linux would be so kind, but unfourtunatly it is not.

    I am a relative newbie to linux and have no idea how to go about getting this to work. I want to mount the drive, just like SUSE did for the other windows partition automatically when I installed it. Any help / ideas will be much appreciated.

  2. #2
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    I think I bought the same card.

    Understand that booting with Grub goes in 3 main steps: Grub is on the MBR of one drive. The MBR must hold information on where the second part of Grub is. The second part of Grub is in the /boot partition. That part must hold either the Linux kernel and related stuff, or it must direct Grub to another bootloader (chainloading). Only after the kernel is loaded will all drives be recognised, including those on the pci card. That is, unless Grub is booted from a drive on the pci card, Grub will not recognize drives on the pci card.

    If you want to have Grub installed on the MBR of one of the drives connected directly to the motherboard, I think you need also to have the /boot directory on a drive connected directly to the motherboard. I think once the kernel is loaded, it will recognize the pci card so you can then have your other partitions and directories on the drive connected to it.

    I have a 40Gb drive with Linux and with Grub installed on the MBR, connected to the pci card (hde). I have other drives connected to the IDE connectors on the motherboard. In the BIOS setup, in the list of drives on the IDE channels, I have the CDROM listed, but all other drives are entered as "none". I have "SCSI" as the first boot device.
    /IMHO
    //got nothin'
    ///this use to look better

  3. #3
    Just Joined!
    Join Date
    Feb 2005
    Posts
    5
    hmm im not sure i really understand what it is you want me to change. right now i have the 20gig with linux and the 80gig with windows plugged directly to my motherboard. plugged into the pci card, i have the new 80gig that is ntfs formated and has some random files on it, no system files.

    Are you saying that i need to add some information to the 80gig plugged into the card so that grub will see it, or that I should switch my linux drive with the new 80gig that is currently plugged into the pci card?

    Also, would it work if i just plug one of my cd or dvd drives into the card instead of a hard disk?

    please bear in mind that I am relatively new to linux and would apreciate instructions on how to actually do any of the things that you suggest.

  4. #4
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    I guess I should have read a little closer. Maybe someone will find my first post useful, anyways. So if I understand, with things arranged as you describe, you can boot Linux from and on a drive connected to the motherboard, but Linux does not recognize the drive on the pci card? If you run 'lspci', does the pci card show? I installed Linux with my pci card in place, and that may be a difference. We need to determine if the card is supported by the kernel. Also, if the drive connected to it is ntfs format, you need to have ntfs support compiled in the kernel. And since you say you are a new user, I've got to ask: do you understand the 'mount' command? If no, do this: enter 'fdisk -l' with an "L", not a "one" and see if the other drive shows up. and if it does, do 'man mount' and read it.

    Quote Originally Posted by JohnHamlin
    Also, would it work if i just plug one of my cd or dvd drives into the card instead of a hard disk?
    It's something to try. Depending on your BIOS, you may still not see the new drive and if Linux does not recognize the pci card, it won't see the CDROM. I'd try it just to see what you get.
    /IMHO
    //got nothin'
    ///this use to look better

  5. #5
    Just Joined!
    Join Date
    Feb 2005
    Posts
    5
    i ran lspci as root and got this in return

    linux:/home/john # lspci
    0000:00:00.0 Host bridge: Intel Corp. 82845 845 (Brookdale) Chipset Host Bridge(rev 11)
    0000:00:01.0 PCI bridge: Intel Corp. 82845 845 (Brookdale) Chipset AGP Bridge (rev 11)
    0000:00:1d.0 USB Controller: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 01)
    0000:00:1d.1 USB Controller: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 01)
    0000:00:1d.2 USB Controller: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 01)
    0000:00:1d.7 USB Controller: Intel Corp. 82801DB/DBM (ICH4/ICH4-M) USB 2.0 EHCIController (rev 01)
    0000:00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev 81)
    0000:00:1f.0 ISA bridge: Intel Corp. 82801DB/DBL (ICH4/ICH4-L) LPC Bridge (rev 01)
    0000:00:1f.1 IDE interface: Intel Corp. 82801DB/DBL (ICH4/ICH4-L) UltraATA-100 IDE Controller (rev 01)
    0000:00:1f.3 SMBus: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus Controller (rev 01)
    0000:01:00.0 VGA compatible controller: nVidia Corporation NV17 [GeForce4 MX 440] (rev a3)
    0000:03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
    0000:03:01.0 USB Controller: NEC Corporation USB (rev 41)
    0000:03:01.1 USB Controller: NEC Corporation USB (rev 41)
    0000:03:01.2 USB Controller: NEC Corporation USB 2.0 (rev 02)
    0000:03:02.0 Multimedia audio controller: Creative Labs SB Audigy (rev 03)
    0000:03:02.1 Input device controller: Creative Labs SB Audigy MIDI/Game port (rev 03)
    0000:03:02.2 FireWire (IEEE 1394): Creative Labs SB Audigy FireWire Port
    0000:03:05.0 Unknown mass storage controller: Integrated Technology Express, Inc. IT/ITE8212 Dual channel ATA RAID controller (PCI version seems to be IT8212, embedded seems (rev 13)

    I assume that the last thing on the list is the card, but i have no idea what to do with this information. . . I entered fdisk -l and was only able to see the 2 drives that are already mounted.

    because none of this was working, i tryed switching the cd drive and when i did this linux couldn't see the cd drive and i stilil didn't see the new hard drive. i am not sure why this is.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •