Find the answer to your Linux question:
Results 1 to 7 of 7
Like many others, I'm having a problem with sound. Built-in sound (on the motherboard), uses the VT8237 with a VT1617A CODEC. Previously, with WinXP, I needed to load some drivers ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Posts
    3

    Another sound problem on FC3... VT8237/VT1617A


    Like many others, I'm having a problem with sound. Built-in sound (on the motherboard), uses the VT8237 with a VT1617A CODEC. Previously, with WinXP, I needed to load some drivers to make this work. It then reported the sound device as "Vinyl AC97 CODEC (WDM)" -- Vinyl probably related to VinylDeck which is VIA's sound control program. At that point, everything was fine, so I believe the hardware is ok.

    I've loaded FC3 and run up2date. Got the new kernel and lots of other stuff.

    The system detects the 8237 and reports the sound device as "VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller" using the module snd-via82xx. Seems reasonable. However, no audio output anywhere when I select the test button.

    I've run a variety of mixers and turned up the volume and unmuted everything I can find. No changes.

    I'm thinking, given the WinXP behaviour, that I need a module specific to the VT1617A, but I can't find any such beast. Any other ideas?

    Partial lsmod output:
    i2c_viapro 7245 0
    i2c_core 20801 6 i2c_dev,w83627hf,eeprom,i2c_sensor,i2c_isa,i2c_via pro
    snd_via82xx 27745 2
    snd_ac97_codec 67489 1 snd_via82xx
    snd_pcm_oss 47989 0
    snd_mixer_oss 17089 2 snd_pcm_oss
    snd_pcm 93001 3 snd_via82xx,snd_ac97_codec,snd_pcm_oss
    snd_timer 29125 1 snd_pcm
    snd_page_alloc 9541 2 snd_via82xx,snd_pcm
    gameport 4929 1 snd_via82xx
    snd_mpu401_uart 9025 1 snd_via82xx
    snd_rawmidi 25953 1 snd_mpu401_uart
    snd_seq_device 8525 1 snd_rawmidi
    snd 52645 11 snd_via82xx, snd_ac97_codec, snd_pcm_oss, snd_mixer_oss, snd_pcm, snd_timer, snd_mpu401_uart, snd_rawmidi, snd_seq_device
    soundcore 10017 2 snd
    via_rhine 23497 0

    Thanks,
    Dave L

  2. #2
    Linux Newbie
    Join Date
    Nov 2003
    Location
    Maryland
    Posts
    105
    I have this same card. Go to the command line and type alsamixer and turn everything up. When finished pres ESC and play some sounds.

  3. #3
    Just Joined!
    Join Date
    Feb 2005
    Posts
    3
    I didn't mention the motherboard type, but it's an MS-7061 (KM400A). It's not a soundcard -- the chips are on the motherboard.

    As I mentioned before, I've tried a number of mixers with no success. Trying your suggestion (plus unmuting everyting) didn't help either. All I get is constant static -- sounds like pulses -- independent of me asking for something to be played.

    However, thanks for the response.
    Dave L

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Enthusiast
    Join Date
    Jun 2004
    Location
    Windsor, CO
    Posts
    656
    Odd, I have almost the same chip xxxxxx35 instead of 37, and I've never had problems with it. Maybe the kernel is missing the module for it? Try re-compiling the kernel and make sure that the support for your chip is in there.
    BTW, I also have to install a driver for it on XP
    Emotions are the key to the soul.
    Registered Linux User #375050

  6. #5
    Just Joined!
    Join Date
    Feb 2005
    Posts
    3
    I don't believe that the problem is with the VT8237 since I also have other machines with that chip. However, this is the only machine that I have that uses the VT1617A CODEC...

    I'm not sure what to look for with module names -- other than snd-82xx and the other modules that I listed initially, what is involved with these parts?

    What motherboard are you using?
    What distribution and kernel version?
    Can you send the output of lsmod while running sound?

    Thanks,
    DaveL

  7. #6
    Just Joined!
    Join Date
    Sep 2006
    Posts
    1

    Same problem here

    It's my laptop and I'm having the same card and same problem. The thing here is if you keep your head phones and listen carefully you can hear the sounds at a very low pitch. Can anyone find a soulution for that? I tried everything but failed. It works well with windows XP.

  8. #7
    Just Joined!
    Join Date
    Jan 2007
    Posts
    1

    Angry Problem Is Not In The Driver !!!

    i have four motherboards MSI P4MAM2 (http://www.msicomputer.com/product/p...AM2-V&class=mb)
    and i got the same problem. Chipset is using VIA 8237 southbridge with VIA VT1617A AC97 codec.

    I figured out that this is generaly not a software problem but problem with the VIA 1617A codec itselfs. Some manufacturers (like MSI) developing cheap motherboards are trying to save costs as possible.

    It looks like the codec itselfs has problem to source enought current, when volume is nearly 100%. Then happens that codecs put audio output to some weird mode and the sound is only playing very quiet and some noise it mixed in.

    To get back to play normally i use this method:
    1.) put master volume to 100%, also PCM volume to 100% or better put all output mixer controls to 100%.
    2.) play some song which is really loud and dynamically (like Soulfly
    3.) try to mute/unmute master volume fast.
    4.) when you finally hear it to play you must fastly put volume down. If not codecs will turn off immediately.
    5.) so you got it, if this will work kill you motherboard manufacturer immediately (and send nuke to VIA)

    I found some solution to raise the limit when the sound start to fall down.
    On motherboard headphones front connector (this is where you have 2 jumpers which route signal to back headphones jack connector), you need to replace those jumpers with some small impedance. I have used 150 Ohm resistors and got no problems. Bigger resistor value means lower current to phones and smaller possibility that codec will stop working when will have not enought instant power.

    Also when you use active spekers with some greater input resistance, this will work also.


    I'm really pissed off that board manufacturers are ignoring this bug are looking like nothing happened..... well, are trying to hide they own incompetency

    It works well with windows XP -> no it does not. Only difference that Windows driver does not allow to set volume so hight that this happen so often. But If you listen to some punk/HC will se that it is the same problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •