Find the answer to your Linux question:
Results 1 to 8 of 8
Hi! I'm running Slackware 10.0 on my Compaq Proliant 6500. I've connected an external HP 1533a tape drive (SureStore DAT8 4/8 GB DDS2) to the SCSI-bus. When I try for ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2005
    Posts
    9

    HP 1533a won't work


    Hi!

    I'm running Slackware 10.0 on my Compaq Proliant 6500. I've connected an external HP 1533a tape drive (SureStore DAT8 4/8 GB DDS2) to the SCSI-bus.

    When I try for example "mt -f /dev/st0 retension", Slackware returns "/dev/st0: No such device". I've also tried /dev/st1, /dev/nst0 etc. None of these devices work.

    When I boot the machine, Slackware mentions "HP 1533a" somewheren in the boot process, so I assume that the drive is being detected by Slackware.

    Can anybody help me?

  2. #2
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    hi,
    SCSI devices are usually given the names sd* e.g sda1 for 1st SCSI device, sdb1 for 2nd SCSI device and so on.

  3. #3
    Just Joined!
    Join Date
    Feb 2005
    Posts
    9
    I tried all possible SCSI-devicenames but nothing works.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    Hi,
    type lsmod into a command prompt and see if the SCSI modules are available.
    Also see what exactly the boot process is saying about the tape drive.

    One more thing you can try is type fdisk -l and see if the tape drive is detected and where it is located.

    These are the only things that I can think of so far.

  6. #5
    Just Joined!
    Join Date
    Feb 2005
    Posts
    9
    Using lsmod: only ide-scsi is available

    Using fdisk -l: nothing is returned

  7. #6
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    Um,
    typing fdisk -l should return all the system storage devices, did you try it under a root login.

    Ok, the lsmod shows that the SCSI drivers are available, and ths is a good sign.

  8. #7
    Just Joined!
    Join Date
    Feb 2005
    Posts
    9
    fdisk -l lists partition tables...according to fdisk itself the usage should be:

    fdisk -l DISK

    So when I type fdisk -l /dev/ida/c0d0, it gives the partition table.

  9. #8
    Just Joined!
    Join Date
    Feb 2005
    Posts
    9
    I should also have the correct stinit.def now:

    manufacturer=HP model="C1533A"
    {
    scsi2logical=1
    can-bsr can-partitions auto-lock
    mode1 blocksize=0 compression=0
    mode2 blocksize=10240 compression=0
    mode3 blocksize=0 compression=1
    mode4 blocksize=10240 compression=1
    }


    When I run stinit the system returns Initialized 0 tape drives. I will have to fix this problem first.

    Does anybody have a stinit.def for such a drive (or a similar drive)?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •