Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
getting lots of hda dma_intr status=0x51 hda dma_intr error=0x84 on Bootup. I have a western digital 80 gig drive. I ran the western digital diags disk on the drive and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Posts
    21

    problem with DMA


    getting lots of

    hda dma_intr status=0x51

    hda dma_intr error=0x84

    on Bootup.

    I have a western digital 80 gig drive. I ran the western digital diags disk on the drive and it was perfect including surface tests.

    It continuously records, through fdisk, 3% non-continuous in the boot partician. I don't get it. I create other particians on the drive and they register fine. I created a DOS partician and then the same linux boot partician in a different section of the drive and the same error. I tried linux red hat 8.0 and fedora and same error.

    Is it a dma issue with the motherboard. Syntax with via chipset. Cheap board I must admit.

    any ideas ???

  2. #2
    Linux Guru Flatline's Avatar
    Join Date
    Feb 2005
    Posts
    2,204
    Don't quote me on this, but I seem to remember bad cables (or trying to run ata66 on ata33 cables) kicking up errors like this "back in the day".
    There are two major products that come out of Berkeley: LSD and UNIX. We don't believe this to be a coincidence.

    - Jeremy S. Anderson

  3. #3
    Just Joined!
    Join Date
    Mar 2005
    Posts
    21

    ahead of you

    Tried several cables including some KNOWN good ones. Good idea though!

    Any extra thoughts you might have ???

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    You might try passing the parameter 'ide=nodma' to the kernel. This link says...
    Quote Originally Posted by link
    Turning off DMA is commonly safe. It might consume
    processor cycles...

    I cannot speak to the specifics of your problem but in general DMA can
    interact with cache memory in complex ways or interact with kernel
    task queues in bad ways if the coherency model of the hardware is
    mismatched to the code/driver.
    IIRC, There is also a parameter to set the speed of the DMA, or something like that but it escapes me now....
    /IMHO
    //got nothin'
    ///this use to look better

  6. #5
    Just Joined!
    Join Date
    Mar 2005
    Posts
    21

    good thought

    (if this is a repeat reply, forgive me because my internet connection is a bit flacky these days)

    for ide=nodma, does that mean recompiling the kernel using menuconfig to set that parameter in the options?

    Thanks...

    If not, please alert me as to what to do

    Thanks....

  7. #6
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817

    Re: good thought

    Quote Originally Posted by davecgs
    for ide=nodma, does that mean recompiling the kernel using menuconfig to set that parameter in the options?
    No, it's pretty easy. If you are booting with Grub, When the splash screen comes up, hit an up/down arrow key to see the menu list and/or stop the countdown-to-boot timer. Use up/down arrow keys to select the version you want to boot and the hit e to edit that version. You should then have the Grub script for that version with 3 lines, with keywords "root", "kernel" and "initrd". Use up/down arrow keys to select the line that starts with "kernel". Press e to edit that line. At the end of the line, add ide=nodma, something like this:
    Code:
    kernel /boot/vmlinuz-whatever root=/dev/hda2 ide=nodma
    When done, hit enter and then b to boot. All of these instructions will be seen on the screens. The change to Grub by this method is not permanent, that is, it only applies for that boot. If all goes well and you are satisfied with the result, you can make the change occur with all boots by editing the file /boot/grub/grub.conf

    If you use LiLO as your bootloader, sorry for the preceding. You will want to accomplish the same thing, but I'm not familiar with Lilo.
    /IMHO
    //got nothin'
    ///this use to look better

  8. #7
    Just Joined!
    Join Date
    Mar 2005
    Posts
    21

    thanks...

    That is the clearest explanation I have ever read for doing anything in linux!

    I wanted to try it today but my flu apparently is still hounding me. Will try it on Saturday and thanks...

  9. #8
    Just Joined!
    Join Date
    Mar 2005
    Posts
    21

    that worked but....

    still getting, when running fdisk, 62 non-continuous blocks. I suspect that happened when the root volume was first built.

    Shutting off DMA definitely was the fix though. How to I deal with the non-continuous blocks though????


    running the chkdsk utilities doesn't seem to rectify the problem.


    thanks...

  10. #9
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    Quote Originally Posted by davecgs
    That is the clearest explanation I have ever read for doing anything in linux!
    Thanks for the feedback. I'm glad I could help.

    I'm not clear on the non-contiguous with fdisk. Are you refering instead to fsck (file system check)? fsck is normally run during boot BEFORE volumes are mounted. I don't know what system you are running or how the fsck is set up, but in any case, I'd suggest you run fsck yourself. The filesystem needs to be not-mounted, or, I think it may be mounted read-only. If you have a separate /boot partition that you want to check, you can umount it and then fsck it. If you want to check the / partition, you will either need to boot in rescue mode with an installation CD, or use a live CD. And check /boot/grub/grub.conf to make sure that on the "kernel" line you have "ro" like this:
    Code:
    kernel /vmlinuz-whatever ro root=/dev/sda2 ide=nodma
    That will cause the / root partition to be mounted read-only until fsck has been run and then it will be made read-write. This is the default behavior for most installs, I think, and if you boot in a verbose mode, you will see related messages on the screen. If this doesn't completely resolve the issue, please let me know exactly when you see the messages about non-contiguous, that is: during boot, after boot, if after, what command did you use. And what more-or-less exactly, did the message say, including related messages before?
    /IMHO
    //got nothin'
    ///this use to look better

  11. #10
    Just Joined!
    Join Date
    Mar 2005
    Posts
    21

    thanks...

    It's Red Hat version 8.0

    For checking, it's the fsck utility that is autorun at the mount of the root partician. I also got it running fdisk (using v) to verify particians.

    I get 3% non-continuous when it runs on startup. I could run it manually and will and let you know the results!

    Thanks...

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •