Find the answer to your Linux question:
Results 1 to 2 of 2
I'm trying to install a Lexmark Z23 USB Printer in RHEL4. I followed the directions at ww.linuxprinting.org. I install the Lexmark Foomatic Kit, and the Lexmark Z33-23 drivers. During the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2004
    Location
    The USA
    Posts
    23

    LexmarkZ23 Install Problem


    I'm trying to install a Lexmark Z23 USB Printer in RHEL4. I followed the directions at ww.linuxprinting.org. I install the Lexmark Foomatic Kit, and the Lexmark Z33-23 drivers. During the installation of the drivers, I get a error saying that I need "libslang.so.6" as it's a depenancy of the Lexmark drivers. I force the installation and continue. Next, I run the "lexmarkinstall" program. At the end, I get this:

    Code:
    Please enter a name for your printer: LexmarkZ23Linux
    
    Installing your printer under the name LexmarkZ23Linux ...
    You appear to be using cups.  Correct? y
    Use of uninitialized value in string eq at /usr/lib/perl5/site_perl/5.8.5/Foomatic/DB.pm line 3309.
    Use of uninitialized value in substitution (s///) at /usr/lib/perl5/site_perl/5.8.5/Foomatic/DB.pm line 3427.
    
    Your printer is successfully installed
    Next...I run the "lexmarkmaintain" program, and it prints the test pages perfectly.
    Then I go to the Printer Configuration window in RHEL, and try to do a CUPS test page. Nothing happens. This is what it displayed to me after I clicked no when it asked if the page was printed correctly:

    Code:
     [08/Mar/2005:16:50:07 -0500] Adding start banner page "none" to job 4.
    I [08/Mar/2005:16:50:07 -0500] Adding end banner page "none" to job 4.
    I [08/Mar/2005:16:50:07 -0500] Job 4 queued on 'LexmarkZ23Linux' by 'root'.
    Nothing else happens.

    Can anyone help pinpoint what the problem is? Thank you

  2. #2
    Just Joined!
    Join Date
    Mar 2005
    Location
    Western Hemisphere
    Posts
    9
    i had a similiar problem with the same model of printer....locally the usb does not seem to work but after switching to a parallel printer cable and then using the CUPS printing utility to configure and test the printer


    good luck

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •