Find the answer to your Linux question:
Results 1 to 7 of 7
I need to get my flash drive working in Linux, This is what I have done. lsusb Bus 001 Device 010: ID 0483:1307 SGS Thomson Microelectronics Cytronix 6in1 card reader ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2004
    Posts
    25

    How do you get a flash drive to work?


    I need to get my flash drive working in Linux, This is what I have done.

    lsusb
    Bus 001 Device 010: ID 0483:1307 SGS Thomson Microelectronics Cytronix 6in1 card reader
    Bus 001 Device 002: ID 0409:0058 NEC Corp. HighSpeed Hub
    Bus 001 Device 001: ID 0000:0000

    This is from lsmod:
    usb_storage 65984 0
    usblp 11264 0
    usbcore 104312 4 usb_storage,usblp,ehci_hcd

    I have this in fstab:
    /dev/sda1 /mnt/flashdrive vfat owner,users 0 0

    I issue this command " mount /dev/sda1 /mnt/flashdrive " then I get "must specify filesystem type" message and the light on the flashdrive blinks off then on.

    Then I issue this command "mount -t vfat /dev/sda /mnt/flashdrive " I get " wrong fs type, bad option, bad superblock on /dev/sda1, or too many mounted file systems"
    I have also tried msdos and auto for filesystem type and still does not work.

    I have read in another forum about needing to enable vfat support or something in the kernel BUT!! I already had this drive mounted and deleted some quickbooks files off of it so it was working somehow.
    Slack 10, 2.6.10 kernel. KDE 3.3
    Thanks.

  2. #2
    Just Joined!
    Join Date
    Nov 2004
    Posts
    25
    Anyone have any idea?????

  3. #3
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,627
    My thought also is you may need to have vfat support built into your kernel, but if it was once working.... Was it workingh before you upgraded to the 2.6.10 kernel and now won't? I have the same problem with a fat 32 partition on my WD external usb drive.

    Unless you need fat 32 between Windows and Linux, why not format your usb reader/writer in ext2 or even reiserFS or ext3, all of which are vastly superior to fat32, and your kernel already supports it.
    Linux Mint + IceWM Registered:#371367 New Members: click here

  4. #4
    Just Joined!
    Join Date
    Nov 2004
    Posts
    25
    Yes, I was told that I need vfat support built into the kernel somewhere else but, It was working in this kernel, just 3 minutes before I tried to copy something to it then all of a sudden I could not mount it. I have already accessed this flash drive and deleted files off of it so vfat is probably already there and there must be a way to access it again. This is driving me CRAZY!! :O I do need it for transferring files from winxp to linux.

  5. #5
    Linux User benjamin20's Avatar
    Join Date
    Oct 2004
    Location
    jacksonville beach FL
    Posts
    317
    i thought for usb type flshdisks you need to use usbfs for the filestystem type. probobly the same for yours
    nVidia G-Force 6600GT (bfg) pci-e: amd 64 2000+ (939): 1024 corsair ram: 2X 80gb seagate harddisk SATA: plextor cd/dvd-read/write cdrom SATA

  6. #6
    Just Joined!
    Join Date
    Nov 2004
    Posts
    25
    No, you can use whatever filesystem you need or want to. I have tried alot and still no luck. I think maybe this drive might be the kind that needs a windows driver and they do not work with Linux pet.

  7. #7
    Just Joined!
    Join Date
    Apr 2003
    Location
    Bucks, UK
    Posts
    40
    This may be a dumb suggestion, but are you sure the flash drive has been partitioned?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •