Find the answer to your Linux question:
Results 1 to 10 of 10
I have installed fedora core 2 on my computer and my sound card (Audigy SB Live) was detected correctly. The problem is I can't hear anything when I press the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2005
    Posts
    5

    my sound card doesn't work


    I have installed fedora core 2 on my computer and my sound card (Audigy SB Live) was detected correctly. The problem is I can't hear anything when I press the test button.What can I do?

  2. #2
    Linux Guru Vergil83's Avatar
    Join Date
    Mar 2004
    Posts
    2,407
    run
    Code:
    alsamixer
    and make sure there isn't something muted.
    If that doesn't work run
    Code:
    alsaconf
    Brilliant Mediocrity - Making Failure Look Good

  3. #3
    Just Joined!
    Join Date
    Apr 2005
    Posts
    5

    My sound card doesn't work

    I have run alsamixer but nothing seems to be mute. Still, when I press the test button, I can't hear anything. What else can I try?

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru Vergil83's Avatar
    Join Date
    Mar 2004
    Posts
    2,407
    here are a few ideas.....
    try
    Code:
    chmod 777 /dev/snd
    http://www.fedoraforum.org/forum/sho...=5257#post5257
    try setting the Audigy(or live) Analog/Digital Output Jack to off
    https://www.redhat.com/archives/fedo.../msg03180.html
    Brilliant Mediocrity - Making Failure Look Good

  6. #5
    Just Joined!
    Join Date
    Apr 2005
    Posts
    5

    Thank you!!!

    I tried running chmod 777 /dev/snd and it worked! I'm so glad I heard sometihing...even if it was just a test sound. Thank you so much! But now can you tell me please how can I listen to some mp3 with xmms? I tried downloading and instaling xmms-mp3-1.2.10-2.2.p.1.fc2.fr.i386.rpm and than I disabled the MPEG Layer Placeholder and I enabled MPEG Layer Player from the I/O Plugins, but I still can's hear anything. What else can I do?

  7. #6
    Linux Guru Vergil83's Avatar
    Join Date
    Mar 2004
    Posts
    2,407

    Re: Thank you!!!

    Quote Originally Posted by geko
    I tried running chmod 777 /dev/snd and it worked! I'm so glad I heard sometihing...even if it was just a test sound. Thank you so much! But now can you tell me please how can I listen to some mp3 with xmms? I tried downloading and instaling xmms-mp3-1.2.10-2.2.p.1.fc2.fr.i386.rpm and than I disabled the MPEG Layer Placeholder and I enabled MPEG Layer Player from the I/O Plugins, but I still can's hear anything. What else can I do?
    make sure that xmms is using alsa and not oss
    Brilliant Mediocrity - Making Failure Look Good

  8. #7
    Just Joined!
    Join Date
    Apr 2005
    Posts
    5

    ok, now it workes!

    I changed the output plugin to alsa, then I reloaded the files in the playlist and now I can hear them just fine. Thanks.

  9. #8
    Just Joined!
    Join Date
    Apr 2005
    Posts
    5

    how can I see my windows partitions?

    I have an ntfs and a fat32 partition on my hard disk that I would like to mount, because most of my music and my movies are over there. How can I do that?

  10. #9
    Just Joined!
    Join Date
    Apr 2005
    Posts
    16
    Getting a fat32 partition to mount is really easy. Assuming that your partition is /dev/hdb1 and you want to mount it in /mnt/windows, just do these commands as root:

    mkdir /mnt/windows (You only need to do this once)
    mount -t vfat /dev/hdb1 /mnt/windows

    To make it mount on every boot automatically, login as root and open up the file /etc/fstab, and add this line:

    Code:
    /dev/hdb1     /mnt/windows     vfat   rw,user     0   0
    On Fedora, getting NTFS partitions to mount is a little harder. By default, Fedora doesn't have support for it for some dumb reason. What you have to do is install support for it in you kernel. First, you need to know what version you're using. Typing uname -r into a terminal will give you this. Then go to http://linux-ntfs.sourceforge.net/rpm/fedora2.html, and grab the right rpm for your kernel version. If the version you have ends in "smp" you need the multi-processor version; otherwise, use the single-processor one. Once you get that over with, you can mount by running as root (assuming that your drive is /dev/hdb2 and you want to mount in /mnt/windows1):

    mkdir /mnt/windows1 (Only do this once)
    mount /dev/hdb2 /mnt/windows1 -t nfts -o umask=0222

    And you can make that mount on every boot by opening up /etc/fstab like before and add this line:

    Code:
    /dev/hdb2     /mnt/windows1     ntfs  ro,user,umask=0222     0   0
    You can witre to your FAT32 partitions from Linux, but you can't write to your NTFS partitions. They're read-only by default. There's a hack to allow writing, but they say that it can screw up the filesystem beyond repair. Scary!! I hope all of this helps

  11. #10
    Just Joined!
    Join Date
    Apr 2006
    Posts
    1

    Unhappy alsaconf on slack

    Hello,

    I just installed Slack 10.2 on my new machine after running it for a while on XP. After I got the nvidia video drivers, I went straight on to get the sound to work. My soundcard is onboard on ASUS A7V8X-X motherboard, and - though the driver CD which shipped with it has this SoundMAX drivers for an AD1980 soundcard - alsaconf only detects via82xx. My guess is that SoundMAX is just some software to run on Windows, and that alsaconf detected correctly (after all, it's a7(VIA)8x-x, right?), but the catch is that the insmod doesn't work. And my sound doesn't work either.
    Would someone lend me a hand or any useful tips?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •