Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
I'm probably gonna seem like a total newb on this one, but how on earth do I setup CUPS? I'm on localhost:631 and I'm up to the Device URI prompt ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Location
    Delran, NJ, USA
    Posts
    10

    CUPS Initial setup, add printer confusion


    I'm probably gonna seem like a total newb on this one, but how on earth do I setup CUPS? I'm on localhost:631 and I'm up to the Device URI prompt and I have't got a clue... I've consulted the giant brain, err, google, and have found nothing concerning device URI's. The printer is directly connected to my parallel port. Am I having problemd or is there a solution that's staring me in the face? HELP!

  2. #2
    Linux Enthusiast puntmuts's Avatar
    Join Date
    Dec 2004
    Location
    Republic Banana
    Posts
    562
    Device URI: parallel:/dev/lp0 I guess
    I\'m so tired .....
    #200472

  3. #3
    Just Joined!
    Join Date
    Mar 2005
    Location
    Delran, NJ, USA
    Posts
    10
    Nope... CUPS complains: client-eror-not-possible... I consulted the freater brain, er, google and found a how-to that calls to recompile parallel support in my kernel... any ideas anyone?

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User zeeone's Avatar
    Join Date
    Oct 2003
    Location
    Third Stone From The Sun
    Posts
    287
    Not sure of the question, but you should have a GUI on what ever desktop you have, that will setup cups and the printer for you.
    Research, research, research before you walk the plank.
    Registered Linux User #398829

  6. #5
    Just Joined!
    Join Date
    Mar 2005
    Location
    Delran, NJ, USA
    Posts
    10
    Tried system-config-printer (I run gnome) to no avail

    I prefer managing CUPS directly via localhost:631 it dosen't seem like I can get any information to the printer... I hooked it to my windoze box to verify the cable and was able to use it right away...

    I've cat'ed to all the ports I can think of /dev/lp0 /dev/par0 /dev/parport0 for all the ones listed and have gotten no such device errors, except on /dev/parport0 where I would get an Invalid Argument error...

  7. #6
    Linux User zeeone's Avatar
    Join Date
    Oct 2003
    Location
    Third Stone From The Sun
    Posts
    287
    What is the make and model of the printer?
    Research, research, research before you walk the plank.
    Registered Linux User #398829

  8. #7
    Just Joined!
    Join Date
    Mar 2005
    Location
    Delran, NJ, USA
    Posts
    10
    I have an HP Laserjet 100

  9. #8
    Just Joined!
    Join Date
    Mar 2005
    Posts
    45
    I have a similar problem, but my printer is on a Windows machine. How do I set a device URI if the printer is on Windows?

  10. #9
    Linux User zeeone's Avatar
    Join Date
    Oct 2003
    Location
    Third Stone From The Sun
    Posts
    287
    HP printers are the most supported printers under Linux and as long as it is a working printer, I have never seen one not set-up under Linux. Every distro that I have loaded, always sets the printer port to lp0 as the default, during the set-up you can change it. Have you tried as the local printer only?
    Research, research, research before you walk the plank.
    Registered Linux User #398829

  11. #10
    Linux User zeeone's Avatar
    Join Date
    Oct 2003
    Location
    Third Stone From The Sun
    Posts
    287
    Quote Originally Posted by mr.popper
    I have a similar problem, but my printer is on a Windows machine. How do I set a device URI if the printer is on Windows?
    If the printer works, turn on the printer, start Winblows. If Winblows sees a working printer, it will promp you of what to do next.
    Research, research, research before you walk the plank.
    Registered Linux User #398829

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •