Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
I'm currently running Red Hat 9 and KDE 3.1, and I have a Kensington optical (not wireless) 5-button wheel mouse. I could care less about the extra buttons, but if ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2005
    Posts
    25

    Scroll wheel mouse won't scroll


    I'm currently running Red Hat 9 and KDE 3.1, and I have a Kensington optical (not wireless) 5-button wheel mouse. I could care less about the extra buttons, but if I could make the scroll wheel work, that would be wonderful. There is no setting for the specific mouse I have (can't remember what it is, but I know none of the choices in the setup wizard ring a bell), so it's on Generic PS/2 wheel mouse. The mouse itself works, but the scroll wheel isn't doing a thing. Anyone have any ideas as to why that might be or what could be done to fix it?

    Thanks

  2. #2
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    In your xorg.conf, make your mouse section have these lines:

    Code:
            Option "Buttons"        "5"
            Option "ZAxisMapping"   "4 5"
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  3. #3
    Just Joined!
    Join Date
    May 2005
    Posts
    25
    Where might that file be located? My system doesn't appear to have it, and find file is coming up empty. My boyfriend, who is running SuSE 9.2 I believe, couldn't find it either.

  4. #4
    Just Joined!
    Join Date
    May 2005
    Posts
    20
    It is located at /etc/X11/xorg.conf

  5. #5
    Just Joined!
    Join Date
    Mar 2005
    Location
    São Paulo / Brazil
    Posts
    14
    instead of xorg, search for xfree86 ...

  6. #6
    Just Joined!
    Join Date
    May 2005
    Posts
    25
    Edit: XF86config had that information...but that code was already there. Scroll wheel still isn't functioning though.

    I've tried other settings, like the Intellimouse setting and one of the Kensington settings, but when I re-enter KDE, the mouse goes completely nuts and it's a miracle I ever get back out to the command line because it's too busy dragging my panel all over the desktop. :P

    This is just odd...any other ideas?

  7. #7
    Just Joined!
    Join Date
    Mar 2005
    Location
    São Paulo / Brazil
    Posts
    14
    Here goes my mouse entry in xorg.conf


    Option "Emulate3Buttons"
    Option "Emulate3Timeout" "50"
    Option "Buttons" "5"
    Option "ZaxisMapping" "4 5"

  8. #8
    Just Joined!
    Join Date
    May 2005
    Posts
    25
    Still no go, unfortunately...very strange. I'm wondering if it's this version of KDE not supporting the scroll wheel or something? Though it should if it's offering wheel mouse options, one would think...

  9. #9
    Linux Guru Cabhan's Avatar
    Join Date
    Jan 2005
    Location
    Seattle, WA, USA
    Posts
    3,252
    Can you please post your entire Mouse section of the file?

    Also, I assume that you've restarted X after modifying the config file?

  10. #10
    Linux Newbie
    Join Date
    Sep 2003
    Location
    St.Charles, Missouri, USA
    Posts
    201
    I dont remember exactly what protocoll is required (i think its "IMPS/2") but i bet the wrong one is set.
    Powered by Gentoo
    never ever ever use the hardened option in make.conf!

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •