Find the answer to your Linux question:
Results 1 to 3 of 3
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1

    Suse 9.3 floppy disk problem


    I have Suse 9.3 pro and am having a problem with my floppy disk drive.

    If I go to Conqueror -> Storage Media -> floppy
    My Computer -> floppy

    I get the following error:
    "The process for the media protocol died unexpectedly."

    'floppy' appears to be /dev/fd0

    If I go into an X termianl window and go to /media/floppy I can browse the contents of the disk with no problems.
    /media/floppy does not appear to be a link.

    the following is what I find in /etc/fstab in relation to the floppy disk drive:

    /dev/fd0 /media/floppy subfs noauto,fs=floppyfss,procuid,nodev,nosuid,sync 0 0

    Now it may be me, so please someone enlighten me, but I expect that when I go into Conqueror or My Computer I expect to click on the floppy icon and then be able to browse the contents of the floppy disk?


  2. #2
    Just Joined!
    Join Date
    Apr 2005
    NC, USA
    I seem to be having the exact same problem, also with SuSE Linux 9.3 Pro. I can access the floppy under /media/floppy in Konquerer, but not under 'Floppy' in 'Storage Media'

  3. #3


    This is indeed a problem with some Suse 9.3 boxes. Perhaps it becomes an issue after Hal is updated via YOU. (? will have to check that out).

    One fix is as follows. Disable HAL via the YAST runlevel services section. Then switch to terminal and type 'su' to gain root priviliges. Crank up 'mc' and switch over to edit the file /etc/fstab. Scroll down to your floppy and cdrom references and change 'noauto' to 'auto' on both. Reboot.

    Not sure if disabling hal will open up any other problems though.

  4. $spacer_open

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts