Find the answer to your Linux question:
Results 1 to 4 of 4
Linux is unable to see my "sound card" I'm running Debian 3.1, "Sarge" on an old Compaq Presario 5220. The so-called "sound card" is one of those damnable integrated ES1869 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2005
    Posts
    4

    Linux and integrated ES1869 audio driver


    Linux is unable to see my "sound card"

    I'm running Debian 3.1, "Sarge" on an old Compaq Presario 5220.
    The so-called "sound card" is one of those damnable integrated ES1869
    audio controllers rather than a real sound card.

    Needless to say, I've got sound under WiNdOwS/MSDOG, but Linux isn't able to
    even see that the sound card is there.

    Here is what I've tried, thus far:

    *: pnpdump can't see a thing, so I have nothing to feed to isapnp

    *: discover can't see a soundcard, but I do get 5 lines of:
    "unknown unknown"

    *: dmesg shows nothing useful

    *: "modprobe sb <various parameters>"
    gives me "Error inserting sb (/lib/.../sb.ko): No such device"

    *: "modprobe snd-es18xx <various parameters>"
    gives me "Error inserting sb (/lib/.../snd-es18xx.ko): No such device"

    *: Hell, in desparation, I even ran a for loop on all the .ko files
    under the /lib/modules/.../sound/ subdirectory in the hopes that
    something would work.
    nothing worked

    *: no such file as /dev/sndstat

    *: alsaconf didn't find a sound card

    *: From what I can tell, nothing of any use in the output of hwinfo

    *: lspci... nope

    *: modinfo soundcore... yup, I have the soundcore module loaded

    One final note.

    I used wine to run the MSDOG esscfg.exe command with the same
    parameters that I have in my autoexec.bat file from that side of the
    computer. The next time I entered KDE, I had a popup message telling
    me that it wasn't able to detect a sound card. Now, I had disabled
    this popup window before, so I suspect that my running esscfg.exe
    under wine might have convinced something that something resembling a
    soundcard might need to be checked again.

    Can anyone offer me any further advice.
    I know that since this *is* an integrated audio controller, there
    really is no soundcard, but I figure that since WiNdOwS/MSDOG can see the
    thing, I should be able to convince Linux to see it.

  2. #2
    Banned Richard_The_Lionhearted's Avatar
    Join Date
    Feb 2005
    Location
    Here, where else?
    Posts
    379
    Don't worry. I've got the sound working on one of these. It only took me 5 minutes

    Enter this command into the terminal(when on desktop)..............

    Code:
    /dev/sndstat
    This will test and let you choose a sound card from a list if it wasn't automatically detected. Try one of the ones with ESS at the beginning and just keep on trying different ones until you hear sound. And yes this *is* a sound card.

    On board sound card but sound card nevertheless.

  3. #3
    Just Joined!
    Join Date
    May 2005
    Posts
    4
    I've tried all your suggestions, but no luck.
    I'm probably going to need to consider compiling a kernel.
    I'll have to put the sound card issue off until next weekend, where I'll probably start another thread asking for even more advice.

    Thank you for all your suggestions.

    This sound card problem has really cut into my Nethack time....

  4. #4
    Just Joined!
    Join Date
    Jul 2006
    Posts
    1
    so... did u fix that problem? I'm a 24 hours old linux user and I have the same sound card, and the same problem. What can I do? I don't know how to compile any kernel Please help... the alsaconf command doesn't help me... It can't find any pnp or pci or... isa sound card (mine is pnp)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •