Find the answer to your Linux question:
Results 1 to 4 of 4
Hi folks, I am neither n00b nor expert to linux, usually I can manage to get my stuff working, but now I have serious problems: I own the following drives: ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2005
    Posts
    5

    DVD+-RW Problem (missing /dev/hdc) [solved]


    Hi folks,

    I am neither n00b nor expert to linux, usually I can manage to get my stuff working, but now I have serious problems:

    I own the following drives:

    hda: Samsung harddisk
    hdb: Samsung harddisk
    hdc: LG DVD+-RW
    hdd: LG DVDROM

    All of them work except hdc!

    I think the problem is related to the kernel and the chipset, but I don't know how to solve it. Here is some more Information:

    Code:
    fir3@k0ol:~$ ls /dev/hd*
    /dev/hda  /dev/hda1  /dev/hda2  /dev/hda5  /dev/hdb  /dev/hdb1  /dev/hdb2  /dev/hdb3  /dev/hdd
    Code:
    fir3@k0ol:~$ dmesg | grep ide
    Nvidia board detected. Ignoring ACPI timer override.
    ACPI: BIOS IRQ0 pin2 override ignored.
    ACPI: IRQ9 used by override.
    ACPI: IRQ14 used by override.
    ACPI: IRQ15 used by override.
    ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
        ide0: BM-DMA at 0xf000-0xf007, BIOS settings: hda:DMA, hdb:DMA
        ide1: BM-DMA at 0xf008-0xf00f, BIOS settings: hdc:DMA, hdd:DMA
    Probing IDE interface ide0...
    ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
     /dev/ide/host0/bus0/target0/lun0&#58; p1 p2 < p5 >
     /dev/ide/host0/bus0/target1/lun0&#58; p1 p2 p3
    Probing IDE interface ide1...
    ide1&#58; Wait for ready failed before probe !
    ide1 at 0x170-0x177,0x376 on irq 15
    Probing IDE interface ide2...
    Probing IDE interface ide3...
    Probing IDE interface ide4...
    Probing IDE interface ide5...
    My burner should be found where it says "ide1: Wait for ready failed before probe !", shouldn't it?

    Code:
    fir3@k0ol&#58;~$ dmesg | grep NFORCE
    NFORCE3-250&#58; IDE controller at PCI slot 0000&#58;00&#58;08.0
    NFORCE3-250&#58; chipset revision 162
    NFORCE3-250&#58; not 100% native mode&#58; will probe irqs later
    NFORCE3-250&#58; BIOS didn't set cable bits correctly. Enabling workaround.
    NFORCE3-250&#58; 0000&#58;00&#58;08.0 &#40;rev a2&#41; UDMA133 controller
    I'm confused about that cable bits line. The drives are correctly jumpered to Secondary Master/Slave. The BIOS finds them...

    Code:
    fir3@k0ol&#58;~$ uname -a
    Linux k0ol 2.6.10-5-amd64-k8 #1 Tue Jun 7 08&#58;26&#58;38 UTC 2005 x86_64 GNU/Linux
    Oh yeah, I'm running Kubuntu 5.04 on my amd64. I also tried cAos 2.0.1 with the same result...

    Could someone please try to help me? I haven't got a clue how to solve that...

    Thanks k0ol

  2. #2
    Banned Tainted_Girl's Avatar
    Join Date
    Jun 2005
    Posts
    57
    It's suppose to be.............

    ide0
    ide1
    ide2
    ide3

    Try with your Primary drives(ones connecter to the primary ide controller) to set one as master and the other to slave.

  3. #3
    Just Joined!
    Join Date
    Jun 2005
    Posts
    5
    I'm not sure if I understood you correctly.

    The harddisks are on primary ide and jumpered correctly.
    The DVD drives are on secondary ide and jumpered correctly.

    There are some sata controllers I don't use on the motherboard (MSI K8N Neo2-54G).

    Did you mean this?
    (Sorry, I'm not a native speaker..)

    Thanks anyway

  4. #4
    Just Joined!
    Join Date
    Jun 2005
    Posts
    5
    ok, I finally got things working...
    Just swapped the dvd drives, now both of them work

    strange stuff

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •