Not to bump and old thread or anything, but I figured I'd post this for anyone interested.

A friend of mine wanted to see a "Linux GUI" the other day, so I switched video cards back to my ATI 9800 PRO. Booted the computer up, and everything worked fine. X windows didn't have a problem with it at all..

Alas I enjoy the little performance boost from my X800 PRO so I switched cards back aftwards. Never thought anything of it. Today I wanted to play with it some more so I switched which hard drives were plugged in so that only my Linux one was, turned it on and left the room for a bit.. when I came back I was completely baffled to be sitting at the graphical login screen. ; )

Whereas I didn't have XF86Config before, I now have the file in the correct place. After checking inside, it wasn't recognizing the card right (obviously, I mean.. it worked. Hehe. ; ) but instead was registering a "Versa AGP card" or something. Needless to say, I didn't try correcting it. ; )

Basically:
1) switched to an older, supported card
2) booted up
3) yay GNOME
4) shut down
5) switch to newer card
6) booted up
7) repeat step 3

Next step, get Linux to register my integrated NIC card. = P