Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
Greetings, I tried searching around the forums and Google for a guide, but have pretty much given up. = ( I've just installed RedHat 9.0 (which I had to install ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2005
    Posts
    8

    Need help to install ATI X800 drivers


    Greetings,
    I tried searching around the forums and Google for a guide, but have pretty much given up. = (

    I've just installed RedHat 9.0 (which I had to install in TEXT MODE 'cause it didn't like my x800), and after booting up it, ofcourse, doesn't like my X800 any more than it did.

    So, I'm stuck in command line "mode" which I'm learning to get around in better. I have downloaded the correct drivers from ATI and placed them on a CD, but I have no clue what to do next. Help, please? = )

    --------------------------------------------------------------

    As a side question, in DOS there's a parameter for dir that tells DOS to list the contents of the directory by pages and putting "MORE" at the bottom of each page.. I've searched for the equivalent in Linux, but alas have found nothing. Instead of such a parameter is there a button you can use to scroll text or something?

    I've been reversing what it displays by using -r but even then I feel as though I'm missing alot.

    I'd actually like that feature for the "help" command cause it apparently has a buttload of commands and I can't see them all.

  2. #2
    Linux Newbie
    Join Date
    Aug 2004
    Posts
    220
    ATI drivers are never fun, but here goes.

    if you don't know the basic commands for console I sugest you read up on them first.

    to my knowledge the driver is a .run file so move it to your hard drive (/home is fine) give it executible permissions (see chmod) and run it (./file)

    this probably work work completely so don't hesitate to post your results/questions/etc.

  3. #3
    Just Joined!
    Join Date
    Jun 2005
    Posts
    8
    Well, after playing for a little bit, I got all of that figured out and done. I can't thank you enough. ; )

    The problem now is, by some ungodly force, I picked the wrong drivers. Or so says the error log from the installation. I'm still pretty sure I checked everything, but I guess I was wrong. Atleast now I know what to do for the most part.

    Last question for now: After I successfully install my drivers, do I have to do anything special to make it use them when I reboot?

    Off to class I go, thanks for the reply. I look forward to the next. = )

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie
    Join Date
    Aug 2004
    Posts
    220
    well I can only think of 2 reasons why someone would install a video driver. 1) to get out of text mode 2) to use 3d acelerated features

    if your goal is 1 you should be able to tell me if your done or not. if you goal is 2 type in a console: glxgears and if your fps is below 1000fps your not done yet.

    so we'll be waiting to hear from you.

    o and if your still in text mode after restart type startx and give us the result (sucess or error message?)

  6. #5
    Just Joined!
    Join Date
    Jun 2005
    Posts
    8
    Well, answer choice 1 is partially correct. I'd prefer to learn commands and such through the terminal window in a GUI environment so I can keep track of other things in the background. (Ie music player, internet browser, etc) Answer choice 2 isn't a real concern right now, I still plan to play games with my copy of WinXP.. until I can lear/figure out how to emulate Windows with Linux. Till I learn that last part, I'm just in Linux to get familiarity.

    As far as whether it worked or not, the process worked. Which is what I was thankful that you taught me, but as I said, I apparently used the wrong Xfree86 version or whatever to choose which packet of drivers to DL from ATI's site. Thus, the drivers installed, but they're for the wrong version of Xfree86 or whatever.

    Blah I went to https://support.ati.com/ics/support/...ge&folderID=27* and downloaded the Installer and the XFree86 4.2 version of the drivers. Apparently that's not what I have despite the book** I have saying it is.

    Using startx earlier gave me an error that I'm sorry I can't remember, but I'm going to boot up Linux and find out exactly what version I have, come back and DL what I need, repeat the process you gave me, and hopefully be done with it. ; )

    Thanks again.

    *Path I took:
    Linux Drivers and Software -> RADEON 8500 Series and higher -> ATI Proprietary Linux x86 Drivers for XFree86 / X.Org Version 8.14.13

    **Red Hat Linux 9: Professional Secrets by Naba Barkakati - I'm taking two classes of Linux as part of my curriculum<sp> for Software Programming, and that's my reference and where I got this copy of Linux.[/url]

  7. #6
    Just Joined!
    Join Date
    Jun 2005
    Posts
    8
    Ok. My book does have the wrong version of xFree86 listed, I tried the correct version (as provided by Linux, itself) and came up with it still not working. Here's a walk through of what I do:

    System login comes up in command line mode.

    Screen flashes a few times and then it says "I cannot start the X server (your graphic interface). It is likely it is not setup correctly. Would you like to view the problem?"

    I hit enter for "Yes."

    It brings all this up:

    XFree86 version 4.3.0 (Redhat Linux release: 4.3.0-2)
    X Protocol Version 11, Revision 0, Release 6.6
    Build Operating System: Linux 2.4.20-3bigmem i686 [ELF]
    Markers: (There were alot that didn't amount to much like "(!!!)Warning, (!!!) Error, etc" so I just wrote these two down)
    (EE) Unable to locate/open config file
    (EE) Error from xf86HandleConfigFile()

    Fatal Server Errors: no screens found


    After I hit enter for "Ok" it asks: "Would you like me to try to run the X config program?"

    I hit enter for "Yes." It asks for the root password which I provide. It sits there for a little bit and then says "Couldn't start X server. Attempting with: Unsupported VGA Device". And then says it will now try again. Finally it brings up the text login screen again and the cycle starts ALL over. = (

    Ok.. Part II. This is what happens when I try to install the drivers after logging in under root in command line mode.

    Installer loads up. Says "You are running a X86 machine with glibc-2.1" and I can only press "Ok." I select to just install the driver, agree to the terms of service, choose the recommended class of installation.

    It shows that "You are running a X86 machine with glibv-2.1" thing.. again..

    Goes through and copies/installs all the files.

    Then, it says, "There were errors during the installation. Check log /usr/share/fglrx/fglrx-install.log". I check the log and it says:

    [Message] Kernal Module: Trying to install a precomiled kernel module
    [Message] Kernal Module: Precompiled kernel module version mismatch
    [Error] Kernel Module: No kernel module build environment


    I close that file, boot up XP and post this mess. /sigh

    And with that, I don't have a clue what to do. If there's more that you think I should have posted, please let me know and I'll try to get that information for you (please don't forget commands. ; ) Aside from that, I'm out of ideas.

    As I said, thanks for the help so far and I really look forward to anything anyone has to say. = ]

  8. #7
    Linux Newbie
    Join Date
    Aug 2004
    Posts
    220
    well I'm a bit unfamilar with red hat's tools so I'm going to have to do a bit of research first to help but here is something that you can do


    these files contain important video info that can help

    /etc/X11/XF86Config
    /etc/X11/xorg.conf

    you can look through them using the less command like this

    /etc/X11/xorg.conf | less

    and copying the info by hand is tiresome so you can dump the file into a floppy either by copying it or redirecting it:

    /etc/X11/xorg.conf | less > /mnt/floppy/file.txt

    just replace /mnt/floppy with whatever the floppy is

  9. #8
    Just Joined!
    Join Date
    Jun 2005
    Posts
    8
    Thanks for the nifty "copy command". = )

    Ok. The directory /etc/X11 does exist, but those files do not. I found a file similiar to one called "XF86Config.old" that contained:

    Code:
    # XFree86 4 configuration created by pyxf86config
    
    Section "ServerLayout"
    	Identifier     "Default Layout"
    	Screen      0  "Screen0" 0 0
    	InputDevice    "Mouse0" "CorePointer"
    	InputDevice    "Keyboard0" "CoreKeyboard"
    	InputDevice    "DevInputMice" "AlwaysCore"
    EndSection
    
    Section "Files"
    # RgbPath is the location of the RGB database.  Note, this is the name of the 
    # file minus the extension &#40;like ".txt" or ".db"&#41;.  There is normally
    # no need to change the default.
    
    # Multiple FontPath entries are allowed &#40;they are concatenated together&#41;
    # By default, Red Hat 6.0 and later now use a font server independent of
    # the X server to render fonts.
    
    	RgbPath      "/usr/X11R6/lib/X11/rgb"
    	FontPath     "unix/&#58;7100"
    EndSection
    
    Section "Module"
    	Load  "dbe"
    	Load  "extmod"
    	Load  "fbdevhw"
    	Load  "glx"
    	Load  "record"
    	Load  "freetype"
    	Load  "type1"
    	Load  "dri"
    EndSection
    
    Section "InputDevice"
    # Specify which keyboard LEDs can be user-controlled &#40;eg, with xset&#40;1&#41;&#41;
    #	Option	"Xleds"		"1 2 3"
    
    # To disable the XKEYBOARD extension, uncomment XkbDisable.
    #	Option	"XkbDisable"
    
    # To customise the XKB settings to suit your keyboard, modify the
    # lines below &#40;which are the defaults&#41;.  For example, for a non-U.S.
    # keyboard, you will probably want to use&#58;
    #	Option	"XkbModel"	"pc102"
    # If you have a US Microsoft Natural keyboard, you can use&#58;
    #	Option	"XkbModel"	"microsoft"
    #
    # Then to change the language, change the Layout setting.
    # For example, a german layout can be obtained with&#58;
    #	Option	"XkbLayout"	"de"
    # or&#58;
    #	Option	"XkbLayout"	"de"
    #	Option	"XkbVariant"	"nodeadkeys"
    #
    # If you'd like to switch the positions of your capslock and
    # control keys, use&#58;
    #	Option	"XkbOptions"	"ctrl&#58;swapcaps"
    # Or if you just want both to be control, use&#58;
    #	Option	"XkbOptions"	"ctrl&#58;nocaps"
    #
    	Identifier  "Keyboard0"
    	Driver      "keyboard"
    	Option	    "XkbRules" "xfree86"
    	Option	    "XkbModel" "pc105"
    	Option	    "XkbLayout" "us"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Mouse0"
    	Driver      "mouse"
    	Option	    "Protocol" "IMPS/2"
    	Option	    "Device" "/dev/psaux"
    	Option	    "ZAxisMapping" "4 5"
    	Option	    "Emulate3Buttons" "no"
    EndSection
    
    Section "InputDevice"
    # If the normal CorePointer mouse is not a USB mouse then
    # this input device can be used in AlwaysCore mode to let you
    # also use USB mice at the same time.
    	Identifier  "DevInputMice"
    	Driver      "mouse"
    	Option	    "Protocol" "IMPS/2"
    	Option	    "Device" "/dev/input/mice"
    	Option	    "ZAxisMapping" "4 5"
    	Option	    "Emulate3Buttons" "no"
    EndSection
    
    Section "Monitor"
    	Identifier   "Monitor0"
    	VendorName   "Monitor Vendor"
    	ModelName    "DDCPROBED"
    	DisplaySize  400	300
    	HorizSync    30.0 - 140.0
    	VertRefresh  50.0 - 160.0
    	Option	    "dpms"
    EndSection
    
    Section "Device"
    	Identifier  "Videocard0"
    	Driver      "vga"
    	VendorName  "Videocard vendor"
    	BoardName   "Unsupported VGA compatible"
    EndSection
    
    Section "Screen"
    	Identifier "Screen0"
    	Device     "Videocard0"
    	Monitor    "Monitor0"
    	DefaultDepth     24
    	SubSection "Display"
    		Depth     24
    		Modes    "1024x768" "800x600" "640x480"
    	EndSubSection
    EndSection
    
    Section "DRI"
    	Group        0
    	Mode         0666
    EndSection
    I used:
    Code:
    find . -name "xorg.*"
    to search for the other file, but alas it found nothing.

    I searched for "XF86Config" and DID find a file, but it was an EXE I believe (Doesn't the "@" symbol mean it's an executable?). It was found in "/usr/X11R6/lib/X11".

    Back to the /etc/X11 directory, it contained these files/folders:

    Code:
    applnk/
    desktop-menus/
    fs/
    gdm/
    lbxproxy/
    prefdm
    proxymngr/
    rstart/
    serverconfig/
    starthere/
    sysconfig/
    twm/
    X@
    xdm/
    XF86Config.old
    XftConfig.README-OBSOLETE
    xinit/
    xkb@
    Xmodmap
    Xresources
    xserver/
    xsm/
    I hope you can gather something from this. = |

  10. #9
    Linux Newbie
    Join Date
    Aug 2004
    Posts
    220
    I'm sorry I'm coming up emtpy here.

    but this is what I would do.

    1) try re-installing (because I don't know how to do video setup for red hat) and telling linux that your card is not ati but something else (generic)

    2)find another card until your more familar with this issue (ebay, garage sales, etc)

    3)try a different distro (knoppix whould probably do it, I personally only got ati working 100% on suse (80% on mdk (it isn't mdk now is it? oh well)) )

    4)search for simialar theads and PM the experts. (ya I guess im not one huh?)


    well good luck with that.

  11. #10
    Just Joined!
    Join Date
    Jun 2005
    Posts
    8
    Heh, well I really appreciate your trying to help. You still taught me a few things so all was not for nothing. ; )

    I'm gonna try reinstalling like you said and telling it about it being a generic card and just overall keep playing with it. = P

    Thanks again for giving some of your time to try and help, take care. = )

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •