Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
I have tried several different data CDs, but am unable to get them to mount. Oddly, music CDs work perfectly. I can also mount any other form of storage. First ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2004
    Posts
    24

    Cannot Mount CD-ROM [Solved]


    I have tried several different data CDs, but am unable to get them to mount. Oddly, music CDs work perfectly. I can also mount any other form of storage.

    First off, I have compiled in support for every CD feature of my 2.6.12 kernel. Also, I have both of my CD drives with SCSI emulation support enabled, so my drives are:
    1. /dev/cdroms/cdrom0, /dev/sr0, /dev/scd0
    2. /dev/cdroms/cdrom1, /dev/sr1, /dev/scd1

    My fstab lines for these drives are as follows:
    Code:
    /dev/cdroms/cdrom0              /mnt/dvd        auto            noauto,user,ro                                  0 0
    /dev/cdroms/cdrom1              /mnt/cdrw       auto            noauto,user,ro                                  0 0
    /dev/sr1                /media/cdrecorder       auto    user,exec,noauto,managed 0 0
    /dev/sr0                /media/cdrom            auto    user,exec,noauto,managed 0 0
    Those last two lines were added automatically be udev.

    Here are the few example attempts of mounting:
    Code:
    # mount -t iso9660 /dev/sr0 /mnt/tmp
    mount: block device /dev/sr0 is write-protected, mounting read-only
    mount: wrong fs type, bad option, bad superblock on /dev/sr0,
           or too many mounted file systems
    # mount -t iso9660 /dev/scd0 /mnt/tmp
    mount: block device /dev/scd0 is write-protected, mounting read-only
    mount: wrong fs type, bad option, bad superblock on /dev/scd0,
           or too many mounted file systems
    # umount /mnt/dvd
    umount: /mnt/dvd: not mounted
    # mount /dev/cdroms/cdrom0
    Segmentation fault
    # ls /mnt/dvd
    #
    As you can see, none of these attempts are successful.

    Lastly, this is what lshw returns when dealing with my CD drives:
    Code:
               *-ide:1
                    description: IDE Channel 1
                    physical id: 1
                    bus info: ide@1
                    logical name: ide1
                    clock: 33MHz
                  *-cdrom:0
                       description: IDE CD-ROM
                       product: SAMSUNG DVD-ROM SD-616Q
                       physical id: 0
                       bus info: ide@1.0
                       logical name: /dev/hdc
                       version: F401
                       capabilities: packet atapi cdrom removable nonmagnetic dma lba iordy
                       configuration: mode=udma2
                  *-cdrom:1
                       description: IDE CD-ROM
                       product: ATAPI CD-RW 52X24
                       physical id: 1
                       bus info: ide@1.1
                       logical name: /dev/hdd
                       version: F.CZ
                       capabilities: packet atapi cdrom removable nonmagnetic dma lba iordy
                       configuration: mode=udma2
         *-scsi:0
              physical id: 1
              logical name: scsi0
              capabilities: emulated
            *-cdrom
                 description: DVD reader
                 product: DVD-ROM SD-616Q
                 vendor: SAMSUNG
                 physical id: 0.0.0
                 bus info: scsi@0:0.0.0
                 logical name: /dev/cdrom2
                 logical name: /dev/dvd1
                 logical name: /dev/scd0
                 logical name: /dev/sr0
                 version: F401
                 capabilities: removable audio dvd
                 configuration: ansiversion=2
         *-scsi:1
              physical id: 2
              logical name: scsi1
              capabilities: emulated
            *-cdrom
                 description: CD-R/CD-RW writer
                 product: CD-RW 52X24
                 vendor: ATAPI
                 physical id: 0.0.0
                 bus info: scsi@1:0.0.0
                 logical name: /dev/scd1
                 logical name: /dev/sr1
                 version: F.CZ
                 capabilities: removable audio cd-r cd-rw
                 configuration: ansiversion=2
    Is there a solution for this problem?

  2. #2
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    The first two sound like a function of you specifying "-t" on the command line. Try omitting the iso9660 for those two and let mount do its thing.

  3. #3
    Just Joined!
    Join Date
    Dec 2004
    Posts
    24
    Code:
    # mount /dev/sr0
    mount: block device /dev/sr0 is write-protected, mounting read-only
    mount: you must specify the filesystem type
    # mount /dev/cdroms/cdrom0
    The second command never did anything; it just froze the console. Even two hours later, nothing happens.

    I also tried it out in GDB, with the "/media/cdrom" mountpoint specified, and nothing different happened. The drive didn't spin up either time.

  4. #4
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    On my system, /dev/cdrom is symbolic link to /dev/hdd. Is your /dev/cdroms/cdrom0 pointing to the right device? Do:
    Code:
    ls -l /dev/cdroms/cdrom0
    /IMHO
    //got nothin'
    ///this use to look better

  5. #5
    Just Joined!
    Join Date
    Dec 2004
    Posts
    24
    Code:
    $ ls -l /dev/cdroms
    total 0
    lrwxrwxrwx  1 root root 6 Jul  8 06:50 cdrom0 -> ../hdc
    lrwxrwxrwx  1 root root 6 Jul  8 06:50 cdrom1 -> ../hdd

  6. #6
    Just Joined!
    Join Date
    Dec 2004
    Posts
    24
    It seems to work with my 2.6.12-gentoo-r4 kernel if I don't use xdm to boot up. I really would like to start up X without having to type "startx", though.

  7. #7
    Linux Engineer
    Join Date
    Sep 2003
    Location
    Knoxhell, TN
    Posts
    1,078
    turn off ide-scsi.. it's not needed.. also, go through each of the options in the kernel for CDROM devices and figure out whether you actually need them or not.. extra crap generates more overhead.

    the segmentation fault that mount gave once has me worried. try recompiling it with just -O1 -pipe as your CFLAGS... also, if your computer is starting to become a bit aged, i would suggest running memtest86 on it to see if the SIGSEGV was caused by bad memory..
    Their code will be beautiful, even if their desks are buried in 3 feet of crap. - esr

  8. #8
    Just Joined!
    Join Date
    Dec 2004
    Posts
    24
    I haven't really gotten it to mount at /dev/cdroms/cdromn. Somehow, mounting in a terminal works perfectly, but only on the SCSI CD-ROMs. When trying to mount any form of my first CD drive in KDE, it stalls.

    I can unmount the drives without a problem, though.

    EDIT: /dev/hdc or hdd stalls even if there isn't a CD in the drive.

  9. #9
    Just Joined!
    Join Date
    Dec 2004
    Posts
    24
    It seems that whenever I start my system up and these lines appear at the bottom of my /etc/fstab, the problems occur:
    Code:
    /dev/sr1                /media/cdrecorder       auto    user,exec,noauto,managed 0 0
    /dev/sr0                /media/cdrom           auto    user,exec,noauto,managed 0 0
    No matter how I change them, the drives just won't mount. The two times my system failed to create these, I was forced to, and without the "exec" flag. The drives, as sr0 and sr1, did mount when the command was invoked from a console. Now that udev has created these lines at the end, the drives aren't able to do a single thing with data.

    When I was on a 2.6.11-gentoo-r9 kernel, I never had a single bit of trouble with this, with or without xdm; in or out of a console. I really wonder what has changed as far as CD handling from that kernel to 2.6.12.

    I hope this helps, since it's the only thing I can say, now.

  10. #10
    Just Joined!
    Join Date
    Dec 2004
    Posts
    24
    Removing SCSI emulation from those two drives fixed it, but now how I am supposed to burn CDs?

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •