Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
and not the 'ub' low speed driver issue, but with 2.6.11.* my pendrive used to plug in and get assigned '/dev/usb/stick' a rule I made myself, now this used to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668

    Anyone having issues with udev rules and 2.6.12?


    and not the 'ub' low speed driver issue,

    but with 2.6.11.* my pendrive used to plug in and get assigned '/dev/usb/stick' a rule I made myself, now this used to work 100% fine, anyway now on .12 it completely ignores that rule and just gets assigned /dev/sd[a,b] or whatever.

    Anyone noticed this too? (Slack 10.1 official with patches)

    I'm sure it'll get fixed if its a simple kernel issue, they seem to mess about a lot with the USB mass-storage side of things.

    thanks a lot.

  2. #2
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    Can you post the rule?

  3. #3
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    kernow@ulysses:~$ cat /etc/udev/rules.d/udev.rules | grep stick
    # usb stick added by kernow
    BUS="usb", SYSFS{serial}="08C1FA4122326956", NAME="usb/stick"
    # end usb stick
    kernow@ulysses:~$

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru loft306's Avatar
    Join Date
    Oct 2003
    Location
    The DairyLand
    Posts
    1,666
    udev is still BUGGY!.......

    it was ok back around the 2.6.8 kernel
    ~Mike ~~~ Forum Rules
    Testing? What's that? If it compiles, it is good, if it boots up, it is perfect. ~ Linus Torvalds
    http://loft306.org

  6. #5
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    it was fine on 2.6.11.* too

    as in rock solid.. my ipod rule still works

    I have had no problems with udev before, I usually find it very good.

    can't see why my rule is getting ignored now suddenly though

  7. #6
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    went from 2.6.12 -> 2.6.12.2 - no fix

    even altered my rule and changed the identifier from {serial} to {model} et cetera. . no fix

    I am considering resorting to 2.6.11 or something, but thats a bit.. meh

    theres no new udev out in the offcial slackware 10.1 tree, so I'm not going to upgrade..

  8. #7
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Yep, from what I've been reading here and there, these issues have been popping up for lots of people using various distros. I went back to 2.6.11 and all seems okay again.

  9. #8
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    thanks for your reply, maybe thats the only thing to do right now


  10. #9
    Linux Enthusiast
    Join Date
    Jun 2005
    Posts
    668
    went back to 2.6.11 too, and everythings working superbly

  11. #10
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    Quote Originally Posted by kern
    went back to 2.6.11 too, and everythings working superbly
    Glad that worked for you. Just noticed that udev 064 came out today. I've not tried it just yet, but maybe it will fix the issues.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •