Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 17 of 17
The second drive definitely does NOT contain the root filesystem - it is used purely for backup purposes. If it is the BIOS of the second drive that is causing ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Jul 2005
    Location
    Manchester, UK
    Posts
    8

    The second drive definitely does NOT contain the root filesystem - it is used purely for backup purposes. If it is the BIOS of the second drive that is causing the problem how might I go about verifying this and fixing it?

    Actually I have just taken a closer look at the drives and I note that the primary (master) drive does not have any jumpers. The three jumper settings listed for this drive are:

    Single or Master: No jumpers
    Master w/ Slave Present: Jumper on pins 5 & 6 (w/ does mean 'with' right?)
    Slave: Jumper on pins 3 & 4

    It would appear that I need another jumper on the primary drive. Could this be the cause of my problem? I'd test but I don't have a spare jumper to hand! The jumpers on the secondary (slave) drive are configured as I would expect.

  2. #12
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    Quote Originally Posted by rigadon
    Master w/ Slave Present: Jumper on pins 5 & 6 (w/ does mean 'with' right?)
    Slave: Jumper on pins 3 & 4
    You may have got it. Yes, with both drives in place on one ribbon cable, you would need to jumper 5 & 6 on the master drive. (w/=with). But if the second drive is not an essential part of the Linux filesystem, you should be able to disconnect that one (disconnect power connector, ribbon cable or both) and then boot right into the first drive. Linux may or may not complain later, but you should be able to get the system mat least mostly up without the second drive.

    Here's hoping it works!
    /IMHO
    //got nothin'
    ///this use to look better

  3. #13
    Just Joined!
    Join Date
    Jul 2005
    Location
    Manchester, UK
    Posts
    8
    Hmmm...having disconnected the second drive I now get the following:

    Code:
    Loading ext3.o module
    Mounting /proc filesystem
    Creating block devices
    VFS: Cannot open root device "LABEL=/" or 00:00
    Please append a correct "root=" boot option
    Kernel panic: VFS: Unable to mount root fs on 00:00
    Any thoughts?

  4. $spacer_open
    $spacer_close
  5. #14
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    Strange. Like the label fell off...

    Just for fun, try this. Get the Grub command line and select to correct menu choice and press 'e' to edit it. Arrow down to highlight the 'kernel' line and press 'e' to edit that. Replace 'root=LABEL=/' with 'root=/dev/hda1'. Press enter to accept changes, press 'b' to boot.

    Make a note of what happens. If you don't like the result, do it again with 'root=/dev/hda2' and finally with 'root=/dev/hda5'. Changes will not be permanent, only for this boot, so no harm done.
    /IMHO
    //got nothin'
    ///this use to look better

  6. #15
    Just Joined!
    Join Date
    Jul 2005
    Location
    Manchester, UK
    Posts
    8
    Yay - fixed it! I just noticed during boot up that the CD-ROM drive was listed as 'hda' not 'hdc'. So I switched the ribbon cables and hey-presto!

    Rather incongruously the BLUE ribbon is now in the BLACK ide socket and the BLACK ribbon is in the BLUE ide socket. I presume these cables must have been switched when it was packed up to be shipped because I haven't touched them since opening the box!

    Today's lesson: never trust someone else's colour coding!

    Thanks for all your help drakebasher and apologies for wasting your time on what turned out to be a very simple problem - I've learnt a lot about debugging IDE errors today if that's any consolation?!

  7. #16
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    Quote Originally Posted by rigadon
    Yay - fixed it!
    Cool :rock:
    /IMHO
    //got nothin'
    ///this use to look better

  8. #17
    Linux Guru loft306's Avatar
    Join Date
    Oct 2003
    Location
    The DairyLand
    Posts
    1,666
    Quote Originally Posted by rigadon
    Today's lesson: never trust someone else's colour coding!
    ~Mike ~~~ Forum Rules
    Testing? What's that? If it compiles, it is good, if it boots up, it is perfect. ~ Linus Torvalds
    http://loft306.org

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •