Find the answer to your Linux question:
Results 1 to 4 of 4
i'm a newbie (been using linux for 5 days! ). i researched on mounting a flask disk on redhat 9 on the net for 2-3 days already. the problem is, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2005
    Posts
    10

    USB mounting on RH 9.0


    i'm a newbie (been using linux for 5 days! ). i researched on mounting a flask disk on redhat 9 on the net for 2-3 days already. the problem is, it only worked on my own Muvo 2.0 (128MB), that means it recognizes mine alone. i tried mounting other flashdisk including Muvo owned by my friends, but to no avail.i tried the follwing commands:

    /etc/fstab
    "/dev/sda1 /mnt/usb auto noauto,user,rw 0 0
    /bin
    i created a text file that contains:
    "mount /dev/sda1"
    /mnt
    created a mount point:
    "/mnt/usb" or a "usb" folder

    still i tried this...
    /mnt/usbhd
    mkdir /mnt/usbhd
    then plugged the USB..
    %mount -t vfat /dev/sda1 /mnt/usbhd
    and i got the error w/c says something like "bash: %mount not a command"???

    still tried another...
    cat /proc/pci|grep -i -usb
    and i got a message about VIA blah..blah..blah...
    i tried the follwing after...
    "modprobe sg" <- modprobe not a command????


    the Q is, will anyone patient enough to tell me about this???
    i am planning to use RH 9 linux as a server for our website project...thanx guys!!!!

  2. #2
    Linux Newbie ihayhurst's Avatar
    Join Date
    Jun 2005
    Location
    UK
    Posts
    138
    OK, we'll try the obvious first (just incase)

    you did type mount (not %mount) if the command was copied then % could well have just been the shell prompt like ">"

    you are the root user for this ?

    The commands may not be in your PATH as a non-root user
    (
    Code:
    echo $PATH
    ) to show your path

    if they were I would expect permission denied or 'only root can do that'

    type
    Code:
    dmesg
    just after putting the stick in to show what device the usb stick has been assigned to (there's a lot of output you just want the end of it....

    Sorry if you know all that , worth checking though

    Ian
    Registerd Linux user #119296

  3. #3
    Linux Newbie ihayhurst's Avatar
    Join Date
    Jun 2005
    Location
    UK
    Posts
    138
    PS, I don't think you're supposed to cross-post here (the board)

    Just come across this in Redhat group....

    Cheers Ian
    Registerd Linux user #119296

  4. #4
    Just Joined!
    Join Date
    Jul 2005
    Posts
    10
    thanx...i'll try this and i'll be back..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •