Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
Hello all. I'm having problems getting my printer to work. It's all setup in CUPS and I can print test pages, but KPrinter gives me this error: Code: Unable to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2005
    Posts
    12

    Printer Problems


    Hello all. I'm having problems getting my printer to work. It's all setup in CUPS and I can print test pages, but KPrinter gives me this error:

    Code:
    Unable to retrieve the printer list. Error message received from manager:
    Connection to CUPS server failed. Check that the CUPS server is correctly installed and running. Error: host not found.
    The CUPS error log shows no errors.

    I have been searching all day for a solution to this with no luck. Any ideas?


    Canon S630 usb
    CUPS 1.1.23
    KDE 3.3

  2. #2
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    I really love my Debian Etch and Sarge boxes, but I must say, I've had a more difficult time setting up printers and sound on them than any other distro including Slack. This thread is full of good information.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  3. #3
    Just Joined!
    Join Date
    Jul 2005
    Posts
    12
    Thank you for your reply. I will try again and post my results.

  4. #4
    Just Joined!
    Join Date
    Jul 2005
    Posts
    12
    Still no luck.

    Failsafe on linuxquestions.org wrote (http://www.linuxquestions.org/questions/history/309683):
    I had a similar problem with my usb connected EPSON STYLUS PHOTO R300. When I installed Sarge and now boot it up the usb printer seems to be recognised fine. Later in the boot sequence it appears that default lp0 gets assigned to my parallel port rather than the usb port. Trying to print something to the printer was like printing to a black hole. I googled for ages to try to see how to fix it from others with the same problem, but to no avail.
    My kern.log shows the same thing:
    Code:
    localhost kernel: drivers/usb/class/usblp.c: usblp0: USB Bidirectional printer dev 3 if 0 alt 0 proto 2 vid 0x04A9 pid 0x1066
    
    localhost kernel: lp0: using parport0 (interrupt-driven).
    Is this the problem? But why would this keep kprinter from finding my cups server? It seems I have another problem.

    Well, I guess this little adventure will have to wait till the weekend when I have time to fully look into it.

    Thanks for your help.

  5. #5
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    The thing is, you said you could test print. I presume from the cups utility, so we know the printer is hooked up correctly and responds to commands. Are you using a firewall? Did you check to see if the ipp port is open? From the command line as root, run:
    Code:
    nmapfe
    And see if port 631 is open. If nmap isn't on your box, I think you can apt-get it. While you're at it, you may want to consider installing guarddog too. It's a nice front end for your security, and will make managing your ports a lot easier.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  6. #6
    Just Joined!
    Join Date
    Jul 2005
    Posts
    12
    Port 631 is open. I'm stumped.

  7. #7
    Just Joined!
    Join Date
    Jul 2005
    Posts
    12
    I just reinstalled CUPS. Now Kprinter retrives the printer list from CUPS, but I cant print a test page! CUPS gives me this error:

    Code:
    client-error-document-format-not-supported
    The CUPS error log show this:
    Code:
    E [19/Jul/2005:19:21:41 +0000] print_job: Unsupported format 'application/postscript'!
    I [19/Jul/2005:19:21:41 +0000] Hint: Do you have the raw file printing rules enabled?
    Now what did I do?

  8. #8
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    I found this...

    Filters are programs used to convert documents from one format to another. The CUPS spooler will do its best to find a suitable filter for the documents you send. If no filter suitable for converting your document is installed you will receive an error similar to lpr: unable to print file: client-error-document-format-not-supported.

    Many applications do not include filters for their documents formats. Documents created with these applications can only be printed from within the application itself, unless the document is exported to PostScript or another standard format.
    From here.

    I wish I could help more, but as I say, I had a time printing from my Debian box too.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  9. #9
    Just Joined!
    Join Date
    Jul 2005
    Posts
    12
    I think I the reason for my troubles is that I'm missing the mime.types and mime.conv files from my cups directory.

    From http://home.nyc.rr.com/computertaijutsu/cups.html

    the cups error log will usually show something like unsupported format 'application/octet-stream' or something similar. In that case in your /etc/cups directory, there is a file called mime.convs. At the end is a line referring to octet-stream. In general, it's commented out, when I've had this problem, uncommenting it and restarting the cups daemon fixed the problem.
    So, I guess I will try to find some sample files to copy.

  10. #10
    Just Joined!
    Join Date
    Jul 2005
    Posts
    12
    I figured it out. I completely removed cups, foomatic, gs, etc. Reinstalled and now it works! I must of had some confilct or something. I guess I didn't remove everything before. Thanks for your help. I cant belive it so easy its hard :o Now my system is pimpin

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •