Find the answer to your Linux question:
Page 2 of 3 FirstFirst 1 2 3 LastLast
Results 11 to 20 of 24
from the command line as root: Code: kdesu xmms It will ask for root password. XMMS will then come up and run under root. Any errors? Can you play music ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630

    from the command line as root:
    Code:
    kdesu xmms
    It will ask for root password. XMMS will then come up and run under root. Any errors? Can you play music files with it?
    Linux Mint + IceWM Registered: #371367 New Members: click here

  2. #12
    Just Joined!
    Join Date
    Aug 2005
    Location
    not.here
    Posts
    11
    well, I get the same error, but the console doesn't give me the /dev/dsp not exist error...

  3. #13
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    So I think the /dev/dsp error is due to you not being in the right "group." Open konqueror and go to /dev. Look for dsp. Right click on it, and click on "proprerties." Then click on the "permissions" tab. root is listed as User. What does it say for, "Group?"
    Linux Mint + IceWM Registered: #371367 New Members: click here

  4. #14
    Linux Newbie
    Join Date
    Jun 2005
    Location
    Yorktown, VA
    Posts
    215
    Thanks for the great info guys! Mine works now!
    MCP | Network+

  5. #15
    Just Joined!
    Join Date
    Aug 2005
    Location
    not.here
    Posts
    11
    Quote Originally Posted by Dapper Dan
    So I think the /dev/dsp error is due to you not being in the right "group." Open konqueror and go to /dev. Look for dsp. Right click on it, and click on "proprerties." Then click on the "permissions" tab. root is listed as User. What does it say for, "Group?"
    /dev/dsp is on "audio" group. I tried changing /dev/dsp permissions, but I still get this error, slightly different:

  6. #16
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    Open Kuser:
    Code:
    kuser
    and find your username. Click on it, then on "Groups." check "audio" so you'll be in that group, then OK and exit. See if that eliminates the /dev/dsp error as user.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  7. #17
    Just Joined!
    Join Date
    Aug 2005
    Location
    not.here
    Posts
    11
    Quote Originally Posted by Dapper Dan
    Open Kuser:
    Code:
    kuser
    and find your username. Click on it, then on "Groups." check "audio" so you'll be in that group, then OK and exit. See if that eliminates the /dev/dsp error as user.
    Is there any way to do this manually? kuser wasn't installed by default, so I downloaded it, but when compiling (./configure) I get an error.... checking X.... can't find X

  8. #18
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    I haven't used Mandrake in a long time, but I think kuser will install perfectly well if you use the Mandrake package utility...
    As root:
    Code:
    urpmi kuser
    Linux Mint + IceWM Registered: #371367 New Members: click here

  9. #19
    Just Joined!
    Join Date
    Aug 2005
    Location
    not.here
    Posts
    11
    Quote Originally Posted by Dapper Dan
    I haven't used Mandrake in a long time, but I think kuser will install perfectly well if you use the Mandrake package utility...
    As root:
    Code:
    urpmi kuser
    Tried that, just said that there was no package named "kuser"

  10. #20
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    I thought you could install kuser as a stand alone package, it's part of a larger package - kdeadmin. So...
    Code:
    urpmi kdeadmin
    ...and see if that gets us kuser. You can also install packages in the Mandrake/Mandriva software package installer that is in the Mandriva Control Center. We gotta get this permission/groups thing taken care of before trying to configure your soundcard. If we still come up empty, just configure it from the command line. Open /etc/group with your favourite editor, I use kate. As user, not root go...
    Code:
    kdesu kate /etc/group
    You'll see several lines, one of which will look like this...
    Code:
    audio::17:
    The "number" of your audio entry may be different. Now, just type in your username after this entry. I'll use your username here...
    Code:
    audio::17:DataX
    Save this file and close kate. This should now enable you to run, (or at least attempt to run), XMMS without the /dev/dsp error...
    Linux Mint + IceWM Registered: #371367 New Members: click here

Page 2 of 3 FirstFirst 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •