Find the answer to your Linux question:
Results 1 to 5 of 5
I have a USB Kensington pocket mouse that I'm trying to get working with my recently installed gentoo box. I emerged xorg, and after that using startx, everything works. The ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Jan 2004
    Location
    Houston, Tx
    Posts
    144

    Having a bit of difficulty with mouse


    I have a USB Kensington pocket mouse that I'm trying to get working with my recently installed gentoo box. I emerged xorg, and after that using startx, everything works. The only thing is the resolution isn't what I'd like. I thought I'd simply change that, but there's no /etc/xorg.conf file. I was wondering if there's a place I need to look to find it somewhere else. Also, when I use Xorg -configure, it sets up my file, but when I cp it to /etc/xorg.conf, it fails to load X saying my mouse doesn't work. Any suggestions?

  2. #2
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    It should be at /etc/X11/xorg.conf

  3. #3
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    Try "xorgconfig", it always works for me.
    When you get to the mouse section of the config, select Option 7, IMPS/2.
    When you are asked what you want it labeled as, the default will be /dev/mouse. Put in "/dev/psaux".
    If this is a wheel mouse, after xorg.conf is written, open up /etc/X11/xorg.conf with your favorite text editor and add tis line to the Mouse section.

    Option "ZAxisMapping" "4 5"
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  4. #4
    Linux Newbie
    Join Date
    Jan 2004
    Location
    Houston, Tx
    Posts
    144
    Quote Originally Posted by Ozar
    It should be at /etc/X11/xorg.conf
    There didn't seem to be any xorg.conf in /etc/X11.

    Try "xorgconfig", it always works for me.
    When you get to the mouse section of the config, select Option 7, IMPS/2.
    When you are asked what you want it labeled as, the default will be /dev/mouse. Put in "/dev/psaux".
    If this is a wheel mouse, after xorg.conf is written, open up /etc/X11/xorg.conf with your favorite text editor and add tis line to the Mouse section.

    Option "ZAxisMapping" "4 5"
    Will give that a try. Thanks.

  5. #5
    Linux Newbie
    Join Date
    Jan 2004
    Location
    Houston, Tx
    Posts
    144
    Update: I have mouse working with my xorg.conf file now, but can't get the proper resolution. I'll post my xorg.conf file as soon as I can get a browser on my gentoo machine. Also, should I make another thread about that, or should I leave it in this one?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •