Find the answer to your Linux question:
Results 1 to 2 of 2
Yeah so I didn't add OSS support when I compiled my kernel and for some reason I get a FATAL: snd_pcm_oss and snd_mixer_oss upon boot. The system hangs at this ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2005
    Posts
    84

    OSS moudles fail to load / support isn't even compiled into my kernel!?


    Yeah so I didn't add OSS support when I compiled my kernel and for some reason I get a FATAL: snd_pcm_oss and snd_mixer_oss upon boot. The system hangs at this error for at least 3 minutes: very annoying. My kernel should not be trying to load these modules. I noticed this started happening when I upgraded alsa to 1.0.9. I then recompiled my kernel to get back to 1.0.8 which I succeeded in doing, I had to reload all my drivers so I know the compilation worked. But I still get this error. Anyone know how I can blacklist the modules? Or even better yet, fix this the right way?

  2. #2
    Linux Guru lakerdonald's Avatar
    Join Date
    Jun 2004
    Location
    St. Petersburg, FL
    Posts
    5,035
    Check /etc/modules.conf, /etc/modprobe.conf.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •