Hey there,
at work i have a debian linux box set up as our company server. we have to take data in on a serial port, no problem. But now we gotta take it in on two serial ports so we installed a 4 serial port pci card that my boss picked up from comp-usa.
there is no documentation for it except a readme.txt with instructions on how to set the card up under redhat.
so, the port does not read. at first, the python script that reads serial errored out and with an i/o error.
then after going thru a lot of trial and error, i was able to get the script to run, but still no data comming in. just a blank.
the device is a Nm9845CV from NetMos.

i tried modprobing parport_serial (read it at this forum) but it didnt work.
the instructions tell me to /proc/pci/ but my debian box has no /proc/pci/
it has a /proc/tty/ but even as root, it will not allow me to see it (even though i can open it in a text editor as root).

all this is to find out what port to use with a setserial command
all i had to go on was what lspci gave me and it doesnt come out quite like the cheezy little readme.txt file says.

i tried it anyway with some numbers in lspci and then the serial port would not error out the script, but still no info passing through.

i feel like i am really close here.
anyone have an idea. i would be so greatfull.
thanks