Find the answer to your Linux question:
Results 1 to 3 of 3
Just installed linux on my friends computer, and added /dev/hda1 to his fstab, it mounted fine, but only root can access it. How would i go about fixing this?...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux User
    Join Date
    Dec 2004
    Location
    Speed School of Engineering
    Posts
    267

    Allow non-root users access to windows partitions


    Just installed linux on my friends computer, and added /dev/hda1 to his fstab, it mounted fine, but only root can access it. How would i go about fixing this?

  2. #2
    Linux Enthusiast aysiu's Avatar
    Join Date
    Jul 2005
    Posts
    633
    Add this line to /etc/fstab

    /dev/hda1 /windows ntfs nls=utf8,umask=0222 0 0

    ...after you've made a directory called "windows," of course.

  3. #3
    Just Joined!
    Join Date
    Jul 2005
    Posts
    84
    Or you could simply put this in the options section of the fstab.

    uid=0000
    where the 0's are his user ID.

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •