Find the answer to your Linux question:
Results 1 to 7 of 7
I don't do alot of printing from Linux, but wanted to try OpenOffice and made a document to print out in writer containing plain text and a small table. After ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2003
    Location
    Cowpens, SC
    Posts
    96

    Printer prob


    I don't do alot of printing from Linux, but wanted to try OpenOffice and made a document to print out in writer containing plain text and a small table. After 3 times printing, the last being 'print selection' with the text and table highlighted, all I get is the last row of the table (All three times)

    I'm using a HP 540 deskjet as a local printer on the LPT, and GS+GIMP CUPS drivers. My test page came out OK. All I have is a black cart, so I haven't tried to print any images or from any other sources.

    Any ideas, guys

  2. #2
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    I'll assume that you're using cups...what driver are you using? Do you have foomatic installed?
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  3. #3
    Just Joined!
    Join Date
    Aug 2003
    Location
    Cowpens, SC
    Posts
    96
    Its CUPS, Ghostscript + GIMP drivers, and although I don't really see the need for foomatic(One printer, connected to the LPT), it is installed.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    OK...what DE are you running? In KDE, the installing a printer is EZ..just go to Control Panel->Peripherals->Printers and add a new printer (make sure you tell it to use cups and that cupsd is running). Then all you have to do is enter the settings and you're done. If the test page doesn't print, then we have problems.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  6. #5
    Just Joined!
    Join Date
    Aug 2003
    Location
    Cowpens, SC
    Posts
    96
    lol

    Uh, I installed the printer to the system during the OS install, and my test page came out just great!

    After that, when trying to print from OpenOffice, it's all screwed up.

    I made a simple document, with a title and a table for me to double check my IP addy's and machine names for my SAMBA probs. The whole thing took maybe a third of a sheet of standard paper, in layout. When I printed it, all I got was half of the last row of the table, and it was turned sideways, like I had it set for 'landscape mode' I went into the printer settings panel and checked to see if the defaults were set for 'legal size' or 'landscape' but no.

    Maybe I have a bug for OpenOffice.org?

  7. #6
    Linux Guru sarumont's Avatar
    Join Date
    Apr 2003
    Location
    /dev/urandom
    Posts
    3,682
    That's wierd...I haven't had any problems printing in OOo. You may have a buggy install or something, but I'm not sure.
    "Time is an illusion. Lunchtime, doubly so."
    ~Douglas Adams, The Hitchhiker's Guide to the Galaxy

  8. #7
    Flo
    Flo is offline
    Just Joined!
    Join Date
    Feb 2005
    Posts
    9
    Hi,

    I just have a similar problem. I think there is a bug with ghostscript since pdf export does not work properly either. It works just fine as root and when printing from staroffice 7. So I guess there is a bug in OOo. The connection to any postscript does not really work properly in a normal user installation. I am using a Lexmark Optera E312, this means full postscript 2 emulation. So it is not the printer.
    So I suggest havng a look in the setup of the gs-setup to solve the problem. Unfortunately I am stll working on it and I have no solution available so far.
    Good luck

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •