Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
I already posted in another area but forgot where exactly regarding configuring my sound card with ALSA... I followed the following steps: alsaconf Here is the console of what it ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie daacosta's Avatar
    Join Date
    Sep 2005
    Location
    Medellín, Colombia
    Posts
    213

    A little help please--Sound Card


    I already posted in another area but forgot where exactly regarding configuring my sound card with ALSA...

    I followed the following steps:

    alsaconf

    Here is the console of what it looked like...

    daacosta@XANFZH4QJ51:~$ su
    Password:
    XANFZH4QJ51:/home/daacosta# alsaconf
    Unloading ALSA sound driver modules: snd-maestro3 snd-ac97-codec snd-pcm-oss snd-mixer-oss snd-pcm snd-timer snd-page-alloc.
    Building card database...


    Running update-modules...
    Loading driver...
    Setting default volumes...

    OK?

    After that I proceeded to answer YES to the following question prompted by the window [ was that wrong? ]

    Do you want to modify /etc/modprobe.d/sound │
    │ (and /etc/modprobe.conf if present)?

    Then I got this:

    OK, sound driver is configured. │
    │ │
    │ ALSA CONFIGURATOR │
    │ │
    │ will prepare the card for playing now. │
    │ │
    │ Now I will load the ALSA sound driver and use │
    │ amixer to raise the default volumes. │
    │ You can change the volume later via a mixer

    Right?

    I then proceeded to run alsamixer and put an M in all entries [ Those are: MASTER, MASTER M, 3D CONTR, 3D CONTR, PCM, LINE, CD AND MIC ]

    Very well... Using the Control Center I also did the following:

    Control Center -> Sound & Multimedia -> Sound System -> Hardware

    At the Select audio device I chose: Advanced Linux Sound Architecture

    I opened the CD Player and I configured it unchecking the digital playback option...

    The result? No sound yet

    What else did I do?

    Control Center -> Sound & Multimedia -> Sound System -> General

    And tested sound and midi...

    The result? Nothing... No sound...

    Ah! One more thing: After running alsaconf all applications that require sound were closed [ i.e., Firefox and the sound mixer that comes on the desktop disappeared ]

    What am I missing?

    Before running to the store to get another soundcard I would like to see if I can solve this issue. In the meantime, I have learned a lot and have gained confidence with the console...

    Can somebody help me please?

    Control Center -> Hardware -> System -> Sound

    Gives as a result:

    SOUND DRIVER: 3.8.1 a-980706 (ALSA v1.0.9rc2 emulation code)

    KERNEL: Linux 2.6.11-x1 #1

    CONFIG OPTIONS: 0

    INSTALLED DRIVERS:
    Type 10:ALSA emulation

    CARD CONFIGURATION:
    ESS-Allegro PCI at 0x1000, irq 5

    Synth and Midi devices: NOT ENABLED IN CONFIG

    AUDIO DEVICES: 0: Allegro (DUPLEX)

    MIXERS: ESS Technology ESS1988



    I am going to try making this work the hard (and fun) way...


    Ah! This also happened to me back in the days when I used Win ME and decided to switch to Win 2000 PRO. I simply had to find the suitable driver and install it [Finding the suitable driver proved difficult and even afterwards I had the sensation that I never solved that problem...]

  2. #2
    Linux Guru bryansmith's Avatar
    Join Date
    Nov 2004
    Location
    /Ontario/Canada
    Posts
    2,619
    If alsaconf recognized the card you should be fine. I think you may have muted the channels when they were actually unmuted. Try going back to alsamixer and unmuting the channels if they are muted.

    Bryan
    Looking for a distro? Look here.
    "There can be no doubt that all our knowledge begins with experience." - Immanuel Kant (Critique of Pure Reason)
    Queen's University - Arts and Science 2008 (Sociology)
    Registered Linux User #386147.

  3. #3
    Linux Newbie daacosta's Avatar
    Join Date
    Sep 2005
    Location
    Medellín, Colombia
    Posts
    213

    All channels are in MM

    From your reply I can feel that I am almost there... Am I?

    I opened alsamixer with the console and all the channels were in MM but... there were other channels I didn't see before:

    MIC (no volume), Phone (no volume), PC Speak (no volume), CAPTURE (no volume)

    Very well... I will raise the volume in those and see what happens...

    Nothing happened...

    In the Alsamixer window there is this:

    Card: ESS Allegro PCI │
    │ Chip: ESS Technology ESS1988 │
    │ View: Playback │
    │ Item: Master Mono [Off]

    That would be for the Master Mono... The remaining items are exactly the same and all of these have their volume raised...

    Is that the way things are supposed to be?

    After testing sound with the control center it didn't work...

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru bryansmith's Avatar
    Join Date
    Nov 2004
    Location
    /Ontario/Canada
    Posts
    2,619
    Did you test the sound right after alsamixer? Run:
    Code:
    alsactl store
    after to store all your settings.

    Okay, alsa recognized your sound card. So something is weird with alsamixer. Is your PCM channel unmuted?

    Bryan
    Looking for a distro? Look here.
    "There can be no doubt that all our knowledge begins with experience." - Immanuel Kant (Critique of Pure Reason)
    Queen's University - Arts and Science 2008 (Sociology)
    Registered Linux User #386147.

  6. #5
    Linux Newbie daacosta's Avatar
    Join Date
    Sep 2005
    Location
    Medellín, Colombia
    Posts
    213

    Let me try this again...

    A channel is muted when MM is shown or when 00 is shown.

    The channels from alsamixer are like this:

    Master, Master M, PCM, CD, MIC --> show a 00

    Phone, PC speak, Line, MIC Boss, External ---> show a MM

    Right after I ran alsamixer I tried to play a CD and no sound...

  7. #6
    Linux Guru bryansmith's Avatar
    Join Date
    Nov 2004
    Location
    /Ontario/Canada
    Posts
    2,619
    I'm going out on a guess here but is there more than one device for your audio? If there is, try using one of them.

    Bryan
    Looking for a distro? Look here.
    "There can be no doubt that all our knowledge begins with experience." - Immanuel Kant (Critique of Pure Reason)
    Queen's University - Arts and Science 2008 (Sociology)
    Registered Linux User #386147.

  8. #7
    Linux Newbie daacosta's Avatar
    Join Date
    Sep 2005
    Location
    Medellín, Colombia
    Posts
    213

    Maybe my soundcard is busted?

    I am about to conclude that my soundcard is busted [As was my modem... Yes, it happened to me when I has Windows on my computer and I had no Internet for a long time...] This was my last session playing with ALSA:

    daacosta@XANJGBN5R18:~$ alsaconf
    bash: alsaconf: command not found
    daacosta@XANJGBN5R18:~$ su
    Password:
    XANJGBN5R18:/home/daacosta# alsaconf
    Terminating processes: 10436 14897.
    Unloading ALSA sound driver modules: snd-maestro3 snd-ac97-codec snd-pcm-oss snd-mixer-oss snd-pcm snd-timer snd-page-alloc.
    Building card database...


    Running update-modules...
    Loading driver...
    Setting default volumes...


    ================================================== =============================

    Now ALSA is ready to use.
    For adjustment of volumes, use your favorite mixer.

    Have a lot of fun!


    XANJGBN5R18:/home/daacosta# alsamixer

    XANJGBN5R18:/home/daacosta# alsactl store
    XANJGBN5R18:/home/daacosta#

    I couldn't play a CD, test a sound How do I know for sure that my soundcard is not damaged?

  9. #8
    Just Joined!
    Join Date
    Nov 2004
    Posts
    45
    Would that also be concerning the ESS-1969-Solo PCI card? From what I understand, an Open Source or OSS driver might help.

  10. #9
    Linux Engineer
    Join Date
    Jul 2003
    Location
    Stockholm, Sweden
    Posts
    1,296
    setting everything to M as you said the first time basicaly means muting all channels..

  11. #10
    Linux Newbie daacosta's Avatar
    Join Date
    Sep 2005
    Location
    Medellín, Colombia
    Posts
    213
    The channels end up with a 00 at the alsamixer (all of them...) In that case they are on, aren't they?

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •