Find the answer to your Linux question:
Results 1 to 2 of 2
I have a sb-live 24bit! pci card. It uses the snd-ca0106 module. Here is my lsmod Code: Module Size Used by nvidia 3708712 12 snd_seq_dummy 3844 0 snd_seq_oss 35584 0 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2005
    Posts
    84

    quick kernel/sound question


    I have a sb-live 24bit! pci card. It uses the snd-ca0106 module. Here is my lsmod

    Code:
    Module                  Size  Used by
    nvidia               3708712  12
    snd_seq_dummy           3844  0
    snd_seq_oss            35584  0
    snd_seq_midi_event      6912  1 snd_seq_oss
    snd_seq                53008  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
    snd_seq_device          8332  3 snd_seq_dummy,snd_seq_oss,snd_seq
    snd_pcm_oss            49184  0
    snd_mixer_oss          18304  1 snd_pcm_oss
    snd_ca0106             28196  0
    snd_ac97_codec         84220  1 snd_ca0106
    snd_pcm                84100  3 snd_pcm_oss,snd_ca0106,snd_ac97_codec
    snd_timer              22788  2 snd_seq,snd_pcm
    snd                    50660  10 snd_seq_dummy,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_
     *oss,snd_mixer_oss,snd_ca0106,snd_ac97_codec,snd_pcm,snd_timer
     
    snd_page_alloc          8836  2 snd_ca0106,snd_pcm
    eepro100               28816  0
    The system still fails to reconize my card. When I run alsaconf, it sees my card as a creative labs card, but says unknown device. I get this when I run alsamixer

    Code:
    jon@milhouse:~$ alsamixer
     
    alsamixer: function snd_ctl_open failed for default: No such file or directory
    and this is my lspci

    Code:
    01:09.0 Multimedia audio controller: Creative Labs: Unknown device 0007

    I noticed that I do not have soundcore loaded, nor is it available on the system. There is no module for that within my kernel config (2.6.13.1). I assume by simply enabling sound card support, soundcore is assumed? I have also tried not building in support for alsa and then installing alsa and all the utils and libraries manualy. Everything compiled perfectly, still no dice. Any ideas?

  2. #2
    Just Joined!
    Join Date
    Jul 2005
    Posts
    84
    Update - I compiled sound support as a module instead of being built in, and left alsa out once again. I then re-compiled alsa and all its dependincies manually again, and my card is still not a known device, although sound core is now a loaded module. So we are past that problem and struck with a new one. Alsaconf still see's it as unknown, and alsamixer still does not run unless I run the ./snddevices script - which alsaproject.org says is only needed for versions onler than 0.9.4, and I am running 1.0.9. But thats neither here nor there, because even when alsamixer does run the card is still unknown. Hopefully I have provided enough information to get some suggestions from you guys.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •