Find the answer to your Linux question:
Results 1 to 7 of 7
I can't get my Nvidia drivers to install. I am running an x86 system. I downloaded that driver from the nvidia site and tried to install it using the readme ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2005
    Location
    meep
    Posts
    20

    Nvidia Drivers


    I can't get my Nvidia drivers to install. I am running an x86 system. I downloaded that driver from the nvidia site and tried to install it using the readme file as a guide. It said to go to where the makefile file was located and type "make install". I tried this, and this is the error that I got:

    Makefile:17: *** missing separator. Stop.

    I can't figure out what's going on. Any ideas?

  2. #2
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    Firstly read this tutorial and follow its steps on getting the nvidia driver installed. But before you go about installing the nvidia driver, make sure that you have make, gcc and the kernel sources installed.
    Life is complex, it has a real part and an imaginary part.

  3. #3
    Just Joined!
    Join Date
    Jul 2005
    Location
    meep
    Posts
    20
    It does the same thing while using the tutorial. I updated using apt-get my distro and all my packages. Nothing has worked.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru Cabhan's Avatar
    Join Date
    Jan 2005
    Location
    Seattle, WA, USA
    Posts
    3,252
    /bump

    I am helping someone who has this exact same problem. I can't seem to find a solution anywhere, and I can't register on the nVidia boards (to search there) because it keeps telling me that what I type in to compare to the picture is incorrect.

    Has anyone found a solution for this problem?

  6. #5
    Linux Newbie
    Join Date
    Sep 2005
    Location
    Wahiawa, Hawaii
    Posts
    125

    Nvidia Driver

    Aloha,
    It took me quite a while but I finally got it to work on Fedora Core 4. Make sure you have Selinux off if you have that on your system. I have a to-do I did for myself around here somewhere....
    On a Salmon (K8S-LA) in a COMPAQ Presario SR1320NX Desktop.
    With no newer version of BIOS..
    Using Fedora Core 4 as root.
    with kernel 2.6.13-1.1526_FC4
    Backed up inittab to inittab.original then using vim changed to boot to runlevel 3
    Backed up grub.conf to grub.conf.original and modified the grub.conf to set "acpi=off" and "noapic"
    >> Was told to turn these off on the Nvidia board which I am a member of.
    Backed up xorg.conf to xorg.conf.origin
    Rebooted.
    Logged in as root and disabled selinux by doing "setenforce 0"
    CD to the directory with the NVIDIA-Linux driver and ran it using the instructions in the readme by doing
    sh NVIDIA-Linux-x86-1.0-7676-pkg1.run
    It needed to compile a custom kernel module
    "If one cannot be downloaded, either because of network connectivity or because one is not provided, the installer will check your system for the required kernel sources and compile the interface for you. If the installer must compile the kernel interface, you must install the kernel-sources package for your kernel."
    Installed OK
    CD /etc/X11
    Edited xorg.conf
    Removed the line:
    Driver "nv"
    and replaced it with the line:
    Driver "nvidia"
    Removed the following lines:
    Load "dri"
    In the "Module" section of the file, add the line (if it does not already exist, it did):
    >>It was already there.
    Load "glx"
    Did "startx -- -verbose 5 -logverbose 5"
    Worked.
    Using vim changed inittab back to runlevel 5.
    Rebooted and back in X
    Edited grub.conf to take out apci=off and noapic and rebooted.
    Xcomes up fine and everything seems good with Selinux on and it shows the splash screen.
    Not sure this will help but it is what ot took for me to get it to work on my system.
    Mahalo,
    Edward
    GNU/Linux is a powerful Free OS. Fear is a powerful motivator. Freedom is sweet. Fear GNU/Linux. Savor Freedom.

  7. #6
    Linux Guru Cabhan's Avatar
    Join Date
    Jan 2005
    Location
    Seattle, WA, USA
    Posts
    3,252
    Heh, thanks. I actually know how to install the drivers, and I walked him through that.

    He's having a particular issue with the Makefile error. That exact one, in fact. And a Google search isn't revealing anything .

    So if anyone knows how to fix that particular error
    Code:
    Makefile:17: *** missing separator. Stop.
    I'd be grateful. Thanks.

  8. #7
    Linux Guru Cabhan's Avatar
    Join Date
    Jan 2005
    Location
    Seattle, WA, USA
    Posts
    3,252
    It seems that the guy downloaded the incorrect driver, which is why he was getting this error. Which is odd since I gave him the link to use. Maybe he told me the wrong arch?

    Anyway, it seems that this problem may arise because of that.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •