Just for you I stuck a Zip drive in my Debian box, but I got it to work. Try this:
Open the root terminal as described before. Do 'modprobe ide-scsi'
Do 'mount /dev/sda /zip'

If you don't get an error, try writing to the Zip:
cp /etc/fstab /zip
Check to see if it worked:
ls /zip

Of course if you did like I suggested before and you deleted /zip and created /mnt/zip, then use /mnt/zip instead, for the mount command as well as cp and ls.

If you see fstab in the output, it worked.
And if it did, use a text editor (gedit) to re-open /etc/fstab to fix the line you added before to change the "/dev/hdd4" to "/dev/sda" so that the line in /etc/fstab looks like this:
Code:
/dev/sda      /zip      auto      noauto,users    0  0
Make sure the "/zip" part agrees with where you want to mount the drive.

Note that you will get an error when booting if the module ide-scsi is not loaded first. But you should be able to do (as root) 'modprobe ide-scsi' and then 'mount /zip' (or 'mount /mnt/zip') to get the drive to work. Once proven, you can add a command to load module ide-scsi automatically during boot. But that's another thread.