Find the answer to your Linux question:
Results 1 to 4 of 4
Sound works but if I reboot after I get alsa working, it doesnt work. If I run alsamixer after I reboot it gives me the snd_ctl_open error. What do I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2005
    Posts
    84

    Alsa works until I reboot


    Sound works but if I reboot after I get alsa working, it doesnt work. If I run alsamixer after I reboot it gives me the snd_ctl_open error. What do I do to make it work upon boot so I dont have to recompile alsa everytime I reboot. The modules load upon boot, but not all of them. snd-pcm-oss and snd-mixer-oss and snd-seq-oss do not load. Even if i load these after a reboot sound is still broke. Any ideas? I've ran alsactl store, and I've tried adding '/usr/sbin/alsactl restore' to my rc.local file. Re-running alsaconf after the reboot does not help either. What gives?

    I get this upon boot

    /usr/sbin/alsactl : Load_state (or something like that)1236: no soundcards found. It's like alsa forgets about my card when I reboot.

  2. #2
    Just Joined!
    Join Date
    Jul 2005
    Posts
    84
    Here is my ****

    modprobe.conf

    Code:
    # --- BEGIN: Generated by ALSACONF, do not edit. ---
    # --- ALSACONF version 1.0.9a ---
    alias snd-card-0 snd-emu10k1
    alias sound-slot-0 snd-emu10k1
    # --- END: Generated by ALSACONF, do not edit. ---
    modules.conf
    Code:
    alias char-major-116 snd
    alias snd-card-0 snd-emu10k1
    
    alias char-major-14 soundcore
    alias sound-slot-0 snd-card-0
    
    alias sound-service-0-0 snd-mixer-oss
    alias sound-service-0-1 snd-seq-oss
    alias sound-service-0-3 snd-pcm-oss
    alias sound-service-0-8 snd-seq-oss
    alias sound-service-0-12 snd-pcm-oss
    lsmod
    Code:
    Module                  Size  Used by
    snd_seq_midi            6624  -
    snd_emu10k1_synth       6568  -
    snd_emux_synth         35784  -
    snd_seq_virmidi         5544  -
    snd_seq_midi_emul       6504  -
    nvidia               3707176  -
    snd_seq_oss            34016  -
    snd_seq_midi_event      5640  -
    snd_seq                51376  -
    snd_pcm_oss            47648  -
    snd_mixer_oss          16808  -
    snd_emu10k1           116164  -
    snd_rawmidi            20288  -
    snd_seq_device          7028  -
    snd_ac97_codec         82972  -
    snd_pcm                82564  -
    snd_timer              21228  -
    snd_page_alloc          7500  -
    snd_util_mem            3240  -
    snd_hwdep               6880  -
    snd                    46532  -
    soundcore               6848  -
    eepro100               27576  -
    NOTE: The lsmod is from before a reboot, after a reboot the 3 modules I listed above do not load.

  3. #3
    Just Joined!
    Join Date
    Jul 2005
    Posts
    84
    C'mon, I'm sure someone knows what to do.

  4. #4
    Just Joined!
    Join Date
    Mar 2005
    Location
    Kansas
    Posts
    30
    alsaconf
    alsactl store
    See if that solves your problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •