Hello every body

I have a big and important problem with an usb external hard drive (Lacie usb 2.0, 50G).
I managed to mount it after having formating it using ext3.mkfs
All was going on quite well util when I forgot to umount it before shuting
down my computer.

When I turned on the computer again, I had the following message when I tried to mount
the device (I'm sorry the message is in french, but more or less it says thath the file
system on /dev/sda1 is corrupted):

[root@danof1 root]# mount /mnt/hd2
mount: type de sys. de fichiers erroné, option erronée, super bloc erroné sur /d ev/sda1,
ou trop de systèmes de fichiers montés

Then I maneged to restore the file system of /dev/sda1 with fsck, but cancelling the
journal, that is the file system type is now ext2.
It was then possible to mount the file system again.

But, when I rebooted the computer, it was not possible any-more to mount the device.

When I plugged the hard drive the /var/log/messages file contains the following
informations:

Oct 15 10:11:32 danof1 su(pam_unix)[2425]: session opened for user root by marc(uid=501)
Oct 15 10:11:36 danof1 kernel: usb 1-1: new full speed USB device using address 2
Oct 15 10:11:37 danof1 kernel: Initializing USB Mass Storage driver...
Oct 15 10:11:37 danof1 kernel: scsi0 : SCSI emulation for USB Mass Storage devices
Oct 15 10:11:37 danof1 kernel: Vendor: SEAGATE Model: ST950212A Rev: 3.05
Oct 15 10:11:37 danof1 kernel: Type: Direct-Access ANSI SCSI revision: 02
Oct 15 10:11:37 danof1 kernel: SCSI device sda: 97691328 512-byte hdwr sectors (50018 MB)
Oct 15 10:11:37 danof1 kernel: sda: assuming drive cache: write through
Oct 15 10:11:38 danof1 kernel: /dev/scsi/host0/bus0/target0/lun0: p1
Oct 15 10:11:38 danof1 kernel: Attached scsi disk sda at scsi0, channel 0, id 0, lun 0
Oct 15 10:11:38 danof1 kernel: Attached scsi generic sg0 at scsi0, channel 0, id 0, lun 0, type 0
Oct 15 10:11:38 danof1 kernel: drivers/usb/core/usb.c: registered new driver usb-storage
Oct 15 10:11:38 danof1 kernel: USB Mass Storage support registered.
Oct 15 10:11:38 danof1 modprobe: FATAL: Module scsimon not found.
Oct 15 10:11:38 danof1 scsi.agent[2508]: disk at /devices/pci0000:00/0000:00:1d.0/usb1/1-1/1-1:1.0/host0/0:0:0:0
Oct 15 10:11:39 danof1 perl: drakupdate_fstab called with --auto --add /dev/scsi/host0/bus0/target0/lun0/part1
Oct 15 10:11:39 danof1 modprobe: FATAL: Could not open '/lib/modules/2.6.3-7mdk/kernel/fs/supermount/supermount.ko.gz': No such file or directory

The last line is due to the fact that I did not want supermount at work (I DO NOT LIKE IT AT ALL!!!)
but since the command supermount -i disable does not work (well it works but if I plugg
something it will mount it on another device) I only manage to cancel the automatic mount it this way
(if someone knows a better way, which is not supermount -i disable: it does not work!!!!(I have mandrake 10.0
installed on my computer)

Then when I do the command: mount /mnt/hd2, there is the following line added to /var/log/messages:

Oct 15 10:56:05 danof1 kernel: VFS: Can't find ext2 filesystem on dev sda1.

The line in fstab corresponding to the device is:

/dev/sda1 /mnt/hd2 ext2 noatime,user,noauto,exec,suid 0 0


The to check the file system I did:

[root@danof1 root]# fsck /dev/sda1
fsck 1.34 (25-Jul-2003)
e2fsck 1.34 (25-Jul-2003)
Couldn't find ext2 superblock, trying backup blocks...
fsck.ext3: Bad magic number in super-block while trying to open /dev/sda1

The superblock could not be read or does not describe a correct ext2
filesystem. If the device is valid and it really contains an ext2
filesystem (and not swap or ufs or something else), then the superblock
is corrupt, and you might try running e2fsck with an alternate superblock:
e2fsck -b 8193 <device>


And that's all.
I tried differents superblock which are indicated in the man page of fsck but
nothing work!

The data on the hard drive are very importants and I would prefer not to format it again.

If someone could help me I would be very very very very very greatfull!!!!!!!!!!!!

Thanks a lot!!!!

Marc.