Hi

I'm trying to make a disk array of 16 sata disk using two Promise sx8 adapters.


Now, the SX8 i a seperate block device driver so the disks should show up as /dev/sx8/0, /dev/sx8/1 etc. But they are not there.

I've configured my kernel with ATAPI and SX8 support. i've run MAKEDEV.

Could you guys help me out here. This is the first Linux machine in the company and i really like to show what it can do!

Thanks in advance
Daniel

Dmesg outputs:
Code:
IO APIC #3......
.... register #00: 03000000
.......    : physical APIC id: 03
.......    : Delivery Type: 0
.......    : LTS          : 0
.... register #01: 00178020
.......     : max redirection entries: 0017
.......     : PRQ implemented: 1
.......     : IO APIC version: 0020
.... register #03: 00000001
.......     : Boot DT    : 1
.... IRQ redirection table:
 NR Log Phy Mask Trig IRR Pol Stat Dest Deli Vect:
 00 001 01  1    1    0   1   0    1    1    D9
 01 001 01  1    1    0   1   0    1    1    E1
 02 000 00  1    0    0   0   0    0    0    00
 03 001 01  1    1    0   1   0    1    1    D1
 04 000 00  1    0    0   0   0    0    0    00
 05 000 00  1    0    0   0   0    0    0    00
 06 000 00  1    0    0   0   0    0    0    00
 07 000 00  1    0    0   0   0    0    0    00
 08 000 00  1    0    0   0   0    0    0    00
 09 000 00  1    0    0   0   0    0    0    00
 0a 000 00  1    0    0   0   0    0    0    00
 0b 000 00  1    0    0   0   0    0    0    00
 0c 000 00  1    0    0   0   0    0    0    00
 0d 000 00  1    0    0   0   0    0    0    00
 0e 000 00  1    0    0   0   0    0    0    00
 0f 000 00  1    0    0   0   0    0    0    00
 10 000 00  1    0    0   0   0    0    0    00
 11 000 00  1    0    0   0   0    0    0    00
 12 000 00  1    0    0   0   0    0    0    00
 13 000 00  1    0    0   0   0    0    0    00
 14 000 00  1    0    0   0   0    0    0    00
 15 000 00  1    0    0   0   0    0    0    00
 16 000 00  1    0    0   0   0    0    0    00
 17 000 00  1    0    0   0   0    0    0    00
Using vector-based indexing
IRQ to pin mappings:
IRQ0 -> 0:2
IRQ1 -> 0:1
IRQ3 -> 0:3
IRQ4 -> 0:4
IRQ5 -> 0:5
IRQ6 -> 0:6
IRQ7 -> 0:7
IRQ8 -> 0:8
IRQ9 -> 0:9
IRQ10 -> 0:10
IRQ11 -> 0:11
IRQ12 -> 0:12
IRQ13 -> 0:13
IRQ14 -> 0:14
IRQ15 -> 0:15
IRQ169 -> 0:16
IRQ201 -> 0:17
IRQ193 -> 0:18
IRQ177 -> 0:19
IRQ233 -> 0:21
IRQ185 -> 0:23
IRQ217 -> 1:0
IRQ225 -> 1:1
IRQ209 -> 1:3
.................................... done.
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
devfs: 2004-01-31 Richard Gooch (rgooch@atnf.csiro.au)
devfs: boot_options: 0x0
Initializing Cryptographic API
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Serial: 8250/16550 driver $Revision: 1.90 $ 54 ports, IRQ sharing enabled
ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
RAMDISK driver initialized: 16 RAM disks of 8192K size 1024 blocksize
serio: i8042 AUX port at 0x60,0x64 irq 12
serio: i8042 KBD port at 0x60,0x64 irq 1
input: AT Translated Set 2 keyboard on isa0060/serio0
EISA: Probing bus 0 at eisa0
EISA: Detected 0 cards.
NET: Registered protocol family 2
IP: routing cache hash table of 4096 buckets, 32Kbytes
TCP: Hash tables configured (established 32768 bind 65536)
NET: Registered protocol family 8
NET: Registered protocol family 20
ACPI: (supports S0 S1 S4 S5)
RAMDISK: cramfs filesystem found at block 0
RAMDISK: Loading 1496 blocks [1 disk] into ram disk... done.
VFS: Mounted root (cramfs filesystem) readonly.
Freeing unused kernel memory: 204k freed
vesafb: probe of vesafb0 failed with error -6
NET: Registered protocol family 1
SCSI subsystem initialized
ACPI: PCI interrupt 0000:02:01.0[A] -> GSI 27 (level, low) -> IRQ 209
scsi0 : Adaptec AIC79XX PCI-X SCSI HBA DRIVER, Rev 1.3.11
        <Adaptec AIC7901 Ultra320 SCSI adapter>
        aic7901&#58; Ultra320 Wide Channel A, SCSI Id=7, PCI-X 50-66Mhz, 512 SCBs

Using anticipatory io scheduler
&#40;scsi0&#58;A&#58;1&#41;&#58; 80.000MB/s transfers &#40;40.000MHz, 16bit&#41;
  Vendor&#58; IBM       Model&#58; DNES-318350W      Rev&#58; SA60
  Type&#58;   Direct-Access                      ANSI SCSI revision&#58; 03
scsi0&#58;A&#58;1&#58;0&#58; Tagged Queuing enabled.  Depth 32
SCSI device sda&#58; 35566501 512-byte hdwr sectors &#40;18210 MB&#41;
SCSI device sda&#58; drive cache&#58; write through
 /dev/scsi/host0/bus0/target1/lun0&#58; p1 p2 < p5 >
Attached scsi disk sda at scsi0, channel 0, id 1, lun 0
kjournald starting.  Commit interval 5 seconds
EXT3-fs&#58; mounted filesystem with ordered data mode.
Adding 755012k swap on /dev/sda5.  Priority&#58;-1 extents&#58;1
EXT3 FS on sda1, internal journal
Real Time Clock Driver v1.12
Generic RTC Driver v1.07
Uniform Multi-Platform E-IDE driver Revision&#58; 7.00alpha2
ide&#58; Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
Capability LSM initialized
md&#58; md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27
device-mapper&#58; 4.1.0-ioctl &#40;2003-12-10&#41; initialised&#58; dm@uk.sistina.com
e1000&#58; Ignoring new-style parameters in presence of obsolete ones
Intel&#40;R&#41; PRO/1000 Network Driver - version 5.2.52-k4
Copyright &#40;c&#41; 1999-2004 Intel Corporation.
ACPI&#58; PCI interrupt 0000&#58;01&#58;01.0&#91;A&#93; -> GSI 18 &#40;level, low&#41; -> IRQ 193
PCI&#58; Setting latency timer of device 0000&#58;01&#58;01.0 to 64
e1000&#58; eth0&#58; e1000_probe&#58; Intel&#40;R&#41; PRO/1000 Network Connection
e100&#58; Intel&#40;R&#41; PRO/100 Network Driver, 3.0.18
e100&#58; Copyright&#40;c&#41; 1999-2004 Intel Corporation
ACPI&#58; PCI interrupt 0000&#58;03&#58;01.0&#91;A&#93; -> GSI 17 &#40;level, low&#41; -> IRQ 201
e100&#58; eth1&#58; e100_probe&#58; addr 0xfe6fe000, irq 201, MAC addr 00&#58;04&#58;23&#58;B7&#58;97&#58;B9
ICH5&#58; IDE controller at PCI slot 0000&#58;00&#58;1f.1
ACPI&#58; PCI interrupt 0000&#58;00&#58;1f.1&#91;A&#93; -> GSI 18 &#40;level, low&#41; -> IRQ 193
ICH5&#58; chipset revision 2
ICH5&#58; not 100% native mode&#58; will probe irqs later
    ide0&#58; BM-DMA at 0xfc00-0xfc07, BIOS settings&#58; hda&#58;pio, hdb&#58;pio
    ide1&#58; BM-DMA at 0xfc08-0xfc0f, BIOS settings&#58; hdc&#58;pio, hdd&#58;pio
usbcore&#58; registered new driver usbfs
usbcore&#58; registered new driver hub
ACPI&#58; PCI interrupt 0000&#58;00&#58;1d.7&#91;D&#93; -> GSI 23 &#40;level, low&#41; -> IRQ 185
ehci_hcd 0000&#58;00&#58;1d.7&#58; Intel Corp. 6300ESB USB2 Enhanced Host Controller
PCI&#58; Setting latency timer of device 0000&#58;00&#58;1d.7 to 64
ehci_hcd 0000&#58;00&#58;1d.7&#58; irq 185, pci mem e082dc00
ehci_hcd 0000&#58;00&#58;1d.7&#58; new USB bus registered, assigned bus number 1
PCI&#58; cache line size of 128 is not supported by device 0000&#58;00&#58;1d.7
ehci_hcd 0000&#58;00&#58;1d.7&#58; USB 2.0 enabled, EHCI 1.00, driver 2004-May-10
hub 1-0&#58;1.0&#58; USB hub found
hub 1-0&#58;1.0&#58; 4 ports detected
Linux agpgart interface v0.100 &#40;c&#41; Dave Jones
agpgart&#58; Detected an Intel i875 Chipset.
agpgart&#58; Maximum main memory to use for agp memory&#58; 439M
agpgart&#58; AGP aperture is 4M @ 0xfe800000
cpci_hotplug&#58; CompactPCI Hot Plug Core version&#58; 0.2
pci_hotplug&#58; PCI Hot Plug PCI Core version&#58; 0.5
pciehp&#58; PCI Express Hot Plug Controller Driver version&#58; 0.4
shpchp&#58; shpc_init &#58; shpc_cap_offset == 0
shpchp&#58; shpc_init &#58; shpc_cap_offset == 0
shpchp&#58; shpc_init &#58; shpc_cap_offset == 0
shpchp&#58; Standard Hot Plug PCI Controller Driver version&#58; 0.4
USB Universal Host Controller Interface driver v2.2
ACPI&#58; PCI interrupt 0000&#58;00&#58;1d.0&#91;A&#93; -> GSI 16 &#40;level, low&#41; -> IRQ 169
uhci_hcd 0000&#58;00&#58;1d.0&#58; Intel Corp. 6300ESB USB Universal Host Controller
PCI&#58; Setting latency timer of device 0000&#58;00&#58;1d.0 to 64
uhci_hcd 0000&#58;00&#58;1d.0&#58; irq 169, io base 0000e800
uhci_hcd 0000&#58;00&#58;1d.0&#58; new USB bus registered, assigned bus number 2
hub 2-0&#58;1.0&#58; USB hub found
hub 2-0&#58;1.0&#58; 2 ports detected
ACPI&#58; PCI interrupt 0000&#58;00&#58;1d.1&#91;B&#93; -> GSI 19 &#40;level, low&#41; -> IRQ 177
uhci_hcd 0000&#58;00&#58;1d.1&#58; Intel Corp. 6300ESB USB Universal Host Controller
PCI&#58; Setting latency timer of device 0000&#58;00&#58;1d.1 to 64
uhci_hcd 0000&#58;00&#58;1d.1&#58; irq 177, io base 0000ec00
uhci_hcd 0000&#58;00&#58;1d.1&#58; new USB bus registered, assigned bus number 3
hub 3-0&#58;1.0&#58; USB hub found
hub 3-0&#58;1.0&#58; 2 ports detected
hw_random hardware driver 1.0.0 loaded
sx8 version 0.8
ACPI&#58; PCI interrupt 0000&#58;02&#58;02.0&#91;A&#93; -> GSI 24 &#40;level, low&#41; -> IRQ 217
sx8&#40;0000&#58;02&#58;02.0&#41;&#58; found 7 interesting devices
sx8&#40;0000&#58;02&#58;02.0&#41;&#58; port 0 device 586114704 sectors
sx8&#40;0000&#58;02&#58;02.0&#41;&#58; port 0 device "Maxtor 6L300S0"
sx8&#40;0000&#58;02&#58;02.0&#41;&#58; port 1 device 586114704 sectors
sx8&#40;0000&#58;02&#58;02.0&#41;&#58; port 1 device "Maxtor 6L300S0"
sx8&#40;0000&#58;02&#58;02.0&#41;&#58; port 2 device 586114704 sectors
sx8&#40;0000&#58;02&#58;02.0&#41;&#58; port 2 device "Maxtor 6L300S0"
sx8&#40;0000&#58;02&#58;02.0&#41;&#58; port 3 device 586114704 sectors
sx8&#40;0000&#58;02&#58;02.0&#41;&#58; port 3 device "Maxtor 6L300S0"
sx8&#40;0000&#58;02&#58;02.0&#41;&#58; port 4 device 586114704 sectors
sx8&#40;0000&#58;02&#58;02.0&#41;&#58; port 4 device "Maxtor 6L300S0"
sx8&#40;0000&#58;02&#58;02.0&#41;&#58; port 6 device 586114704 sectors
sx8&#40;0000&#58;02&#58;02.0&#41;&#58; port 6 device "Maxtor 6L300S0"
sx8&#40;0000&#58;02&#58;02.0&#41;&#58; port 7 device 586114704 sectors
sx8&#40;0000&#58;02&#58;02.0&#41;&#58; port 7 device "Maxtor 6L300S0"
 /dev/sx8/0_0&#58; unknown partition table
 /dev/sx8/0_1&#58; unknown partition table
 /dev/sx8/0_2&#58; p1
 /dev/sx8/0_3&#58; unknown partition table
 /dev/sx8/0_4&#58; unknown partition table
 /dev/sx8/0_6&#58; p1
 /dev/sx8/0_7&#58; unknown partition table
sx8&#40;0000&#58;02&#58;02.0&#41;&#58; 7 ports activated
sx80&#58; pci 0000&#58;02&#58;02.0, ports 8, io fc400000, irq 217, major 160
ACPI&#58; PCI interrupt 0000&#58;02&#58;03.0&#91;A&#93; -> GSI 25 &#40;level, low&#41; -> IRQ 225
sx8&#40;0000&#58;02&#58;03.0&#41;&#58; found 4 interesting devices
sx8&#40;0000&#58;02&#58;03.0&#41;&#58; port 0 device 586114704 sectors
sx8&#40;0000&#58;02&#58;03.0&#41;&#58; port 0 device "Maxtor 6L300S0"
sx8&#40;0000&#58;02&#58;03.0&#41;&#58; port 1 device 586114704 sectors
sx8&#40;0000&#58;02&#58;03.0&#41;&#58; port 1 device "Maxtor 6L300S0"
sx8&#40;0000&#58;02&#58;03.0&#41;&#58; port 2 device 586114704 sectors
sx8&#40;0000&#58;02&#58;03.0&#41;&#58; port 2 device "Maxtor 6L300S0"
sx8&#40;0000&#58;02&#58;03.0&#41;&#58; port 3 device 586114704 sectors
sx8&#40;0000&#58;02&#58;03.0&#41;&#58; port 3 device "Maxtor 6L300S0"
 /dev/sx8/1_0&#58; p1
 /dev/sx8/1_1&#58; unknown partition table
 /dev/sx8/1_2&#58; unknown partition table
 /dev/sx8/1_3&#58; unknown partition table
sx8&#40;0000&#58;02&#58;03.0&#41;&#58; 4 ports activated
sx81&#58; pci 0000&#58;02&#58;03.0, ports 8, io fc200000, irq 225, major 161
input&#58; PC Speaker
e1000&#58; eth0&#58; e1000_watchdog&#58; NIC Link is Up 100 Mbps Full Duplex