Find the answer to your Linux question:
Results 1 to 5 of 5
Hello people I am fairly new to Linux and totally new to Ubuntu, so please have patience. I have a fresh Ubuntu 5.10 (for AMD64) install and it didn't recognize ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2005
    Posts
    2

    Can't install NFORCE driver


    Hello people I am fairly new to Linux and totally new to Ubuntu, so please have patience.

    I have a fresh Ubuntu 5.10 (for AMD64) install and it didn't recognize the built-in network card. My system is a shuttle PC model SN85G4v3 with NVIDIA nForce™3 250 Northbridge (http://global.shuttle.com/Product/Ba...N85G4%20V3.asp).

    I tried installing the drivers available from the NVIDIA site. I downloaded the NFORCE-Linux-x86_64-1.0-0306-pkg1.run file and ran it as root. After the license screen, it says:

    No precompiled kernel interface was found to match your kernel; this means that the installer will need to compile a new kernel interface.

    I clicked OK and proceeded. The next screen tells me that "gcc-version-check failed", it seems the kernel was compiled with 3.4 and my current compiler is gcc 4.0. I am not sure how to revert to 3.4 nor if this is necessary, so I just ignored the warning and proceeded.

    The installer then builds the module name "nvnet.ko" (and I checked that it exists in the filesystem), but after building it show a screen saying:

    ERROR: Unable to load the kernel module 'nvnet.ko'. This is most likely because the kernel module was built using the wrong kernel source files. Please make sure you have installed the kernel source files for your kernel; on Red Hat Linux systems, for example, be sure you have the 'kernel-source' rpm installed. If you know the correct kernel source files are installed, you may specify the kernel source path with the '--kernel-source-path' commandline option.

    Well, I am stuck at this point, because none of the packages available on Synaptic seem to be kernel sources (I did find kernel headers but I suppose this is not the same thing).

    I believe it should be important to note that my kernel is 2.6.12-9-amd64-generic.

    I appreciate any help solving this.

    Matheus

  2. #2
    Just Joined!
    Join Date
    Oct 2005
    Posts
    2

    I have same problem...

    I have same problem but i believe that recompiling the kernel with the newer gcc will fix it. Although i have no clue how to do so....

    try using the command
    apt-cache search linux-headers

    or
    apt-cache-search linux-source

    this will give you the available packages for it


    thats all i know man... hope you can help me out

    You're computer looks sweet...probably runs good too

  3. #3
    Linux Engineer d38dm8nw81k1ng's Avatar
    Join Date
    Mar 2005
    Location
    Newcastle
    Posts
    793
    if the ubuntu CD doesn't include the sources for the linux kernel then you have to download them manually. then you will have to configure the kernel. i only know the link to the gentoo handbook, but i think that the procedure should be the same. just skip down to "Default: Manual Configuration" and follow the instructions from there. http://www.gentoo.org/doc/en/handboo...?part=1&chap=7

    NOTE: ignore the bit about genkernel completely. if anyone knows the linkage to the proper kernel HOWTO then use that instead.
    Here's why Linux is easier than Windows:
    Package Managers! Apt-Get and Portage (among others) allow users to install programs MUCH easier than Windows can.
    Hardware Drivers. In SuSE, ALL the hardware is detected and installed automatically! How is this harder than Windows' constant disc changing and rebooting?

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Oct 2005
    Posts
    2
    Looks easy i'll give it a try, Thanks for the info...

  6. #5
    Just Joined!
    Join Date
    Oct 2005
    Posts
    2
    I ended up installing a second network card and downloaded the linux kernel sources using Synaptic (no need to manually download that). I also installed the correct gcc version (3.3) which asked by the setup program.

    Despite this, the module can't still be loaded and I get an error message saying "cannot load module nvnet.ko" or something like that. Has anyone bumped into this?

    On the other hand, the audio driver worked flawlessly after I switched from gcc 4.0 to gcc 3.3. Great, now I have sound but no internet

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •