Find the answer to your Linux question:
Results 1 to 4 of 4
Hello folks - Guess this is a hello on my first post and a question:- I live in Oxford, England and am definitely a newbie to Linux although im getting ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2003
    Posts
    5

    USB Memory Stick & Digital Camera Fight


    Hello folks -

    Guess this is a hello on my first post and a question:-

    I live in Oxford, England and am definitely a newbie to Linux although im getting better ........ slowly ....


    Eitherway, here goes ...

    I have a USB Memory stick and a digital Camera which I connect through the USB -

    My Laptop has only ONE USB port so I have to swap them over.

    I can connect BOTH no trouble. Problem is once one has been mounted then I cannot unmount and then remount the other device. Something in Linux is stuck on the old device - any clue how I can determine what to do?

    Also I just installed Debian 3 on my desktop machine and cannot mount my USB Stick at all -

    Hotplugging is installed (I think) and DMESG is returning the USB messages which I think means that it can see the Memory stick -

    I have tried cycling through various locations in /dev/ which worked on my Laptop and the Older RedHat I had installed on this same box but I cannot find the device !

    Anyone know of some kind of auto mounting dev probe device that will scan your drives?

    or something ...

    Any ideas on this ?


    Thanks ....

  2. #2
    Linux Engineer kriss's Avatar
    Join Date
    Jun 2003
    Posts
    1,113
    where do you mount it?

    do something like this:

    lsof | grep mntpoint and you should get the pid and be able to close it.. Good luck

  3. #3
    Just Joined!
    Join Date
    Sep 2003
    Posts
    5
    Hang on let me just narrow this down:-

    So you are are saying that once I have mounted EITHER my Cam or Memory stick and then unmounted one of these with the intention of mounting the other one a PID is still remaining open in some fashion and it is this which is preventing the NEXT mount attempt with the new device from proceeding ?

    (At work at the mo without my camera but I will be trying this as soon as I get get home)

    - thanks for your advice !

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Engineer kriss's Avatar
    Join Date
    Jun 2003
    Posts
    1,113
    No, not quite what I meant. If you for example are copying pictures from your mem.stick with konqueror ( just an example ) and you forget to close konqueror or it crashes or something, knowing the pid can help you clear up whats clogging up the mnt-point. It has happened to me a couple of times using a cdrom.

    The second one, sorry don't know, try to log in the usual spots, like system logs, dmesg, etc

    Good luck

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •