Find the answer to your Linux question:
Results 1 to 7 of 7
Hi folks I'm new to linux and using it in a work environment... I have a Nvidia Quadro FX 1400 graphics card but I've lost the driver... when I try ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2005
    Posts
    6

    help... nvidia driver lost


    Hi folks

    I'm new to linux and using it in a work environment... I have a Nvidia Quadro FX 1400 graphics card but I've lost the driver... when I try to open one of my graphics packages I get an error saying

    GLX missing on display :0.0

    I've looked around a few site and they all mention an xorg.conf file that should reisde in /etc/X11... This file does not exist on my installation (The installation was done prior to my arrival). I do have a file called XF86Config which has also been mentioned. I'm just a bit confused as to what I should do to get my drivers back.

    Any information would be appreciated.

    H

  2. #2
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    You could just reinstall your drivers and edit your XF86Config (or XF86Config-4, whichever you have).

    http://www.nvidia.com/object/linux_d..._1.0-7676.html
    Registered Linux user #270181
    TechieMoe's Tech Rants

  3. #3
    Just Joined!
    Join Date
    Oct 2005
    Posts
    6
    Tried to edit the XFree86Config file, but now I've got a permanent hang on start up... I can't even get to a console... what do I do!?!

    Doh!

  4. #4
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    Apparently your system is set to runlevel 5 (graphical boot), so it's trying to start up X Windows at boot. You might try booting into runlevel 3 until you figure out what's wrong with your video settings. There are a couple of ways to do this:

    1.Pass a "3" parameter to Grub at boot.

    2.Edit your /etc/inittab and look for a section like this:
    Code:
    id:5:initdefault
    Change the 5 to a 3, save, and reboot.
    Registered Linux user #270181
    TechieMoe's Tech Rants

  5. #5
    Just Joined!
    Join Date
    Oct 2005
    Posts
    6
    Great idea... but how do I tell Grub how to do this... I can't seem to load the kernel. I know the partition, but not the absolute path to the kernel... is ther a default I'm not aware of?

    I just need to change 2 lines in the XF86Config file and I'll be able to boot properly, but I can't get into anything to do so!


  6. #6
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    Quote Originally Posted by hassantm
    Great idea... but how do I tell Grub how to do this... I can't seem to load the kernel. I know the partition, but not the absolute path to the kernel... is ther a default I'm not aware of?
    You can edit your boot lines by selecting them and hitting "e" at boot. Edit your boot line where it has the kernel listed, something like this:
    Code:
    kernel /vmlinuz ro root=/dev/hda1
    Add a "3" to the end of that line and see if that works for you. It would look something like this:
    Code:
    kernel /vmlinuz ro root=/dev/hda1 3
    Registered Linux user #270181
    TechieMoe's Tech Rants

  7. #7
    Just Joined!
    Join Date
    Oct 2005
    Posts
    6
    Wonderful... it worked!! Thanks a lot.

    For my next trick i need to get my Nvidia card working again!

    Thanks so much for your help
    H

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •