Find the answer to your Linux question:
Results 1 to 2 of 2
I am having trouble getting my usb flash drive working. I have used it on a Linux before, but my problem here is with the Mother board, or configuration. I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2004
    Posts
    24

    usb flash drive trouble, with complex drive layout


    I am having trouble getting my usb flash drive working. I have used it on a Linux before, but my problem here is with the Mother board, or configuration.

    I am running a an Asus A8NSLI Delux,
    It has two sata controllers, one nvidia and one silicon image
    I have the nvidia controller configured to act as a standard sata controller
    with all 4 ports acting as hard drive ports with one 250 GB drive on sata1
    I have the silicon image controller configured as a raid device with two
    raptors set up in a raid 0.

    Finally I am running my slack 10.2 from the on board pata 1 controller

    Now here is the kicker. How the heck to figure out where to mount the flash drive. I know nix sees the sata drives as scsi devices, and I have tried to simply count the drives and then move on to the next drive, to no avail.

    any help would be great.

    ytinrete

  2. #2
    Just Joined!
    Join Date
    Nov 2004
    Posts
    45
    Even though I run RedHat, I can most likely tell you why it may be confusing:
    • You have the drive info because you know what to call it by name.
      Linux has this information when you plug it in.
      Except for the Hardware Browser in X, there may be no way to tell, or so it may seem.

    What you ought to do is see if you can find the device file (/dev/sda or what not) that Linux assumes will be used for your USB Flash drive. Once you find that out, you need to know that Linux does not automatically create a mount point for that kind of device (Flash drive); you have to do that manually. So:
    1) Use the Hardware Browser to look for your Flash drive.
    Because Linux DOES see the brand name, look for something
    that says 'Device : /dev/device', where device is 'sda' or something
    like that. It should show up in the hardware browser.
    2) Remembering the '/dev/device' phrase, make a folder on your
    disk. I recommend putting it in the /mnt folder, because that may
    be typically where Linux mounts the floppy or cd or what other drives
    you may have.
    3) Issue the mount command to tell it to use /mnt/flash for /dev/device.

    In other words:
    Code:
    mkdir /mnt/flash
    mount -t fstype /dev/device /mnt/flash
    Or, you may be able to:
    Code:
    mount /dev/device /mnt/flash
    Again, right now I use RedHat, but there should be a hardware browser on Slackware. I hope this helps.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •