Find the answer to your Linux question:
Results 1 to 7 of 7
Hey I'm new to both the linux community as well as these forums. My problem consists of having both my onboard sound and creative live! soundcard being installed. The onboard ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2005
    Posts
    2

    Onboard sound and pci sound both installed at the same time....problem


    Hey I'm new to both the linux community as well as these forums. My problem consists of having both my onboard sound and creative live! soundcard being installed. The onboard is I guess the default as sound will only come out when plugged in to it. My question is how do you uninstall hardware in linux so that I can resolve this issue. Before you suggest disabling the onboard in bios, I have already done this and since I've done this I'm really confused as to how linux can see my onboard sound when technically it doesn't have any resources assigned to it. Anyways any suggestions are appreciated, thanks.

    Motherboard: Biostar M7VKD
    Onboard Sound: AC'97
    PCI Soundcard: Creative Live!
    Linux: Mandriva 2006 RC2

  2. #2
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    I'm not sure with sound but I have onboard video and a seperate video card and you don't "uninstall" the onboard video you just don't use it. So I plug my monitor into my AGP card and make sure that I have proper drivers and the such for that video to work. Now I may be completely wrong but I think you just need to get right ALSA stuff for your creative card and make sure that these modules are loaded and not the one's for your onboard audio. I'm not sure about mandriva but there is probably some control center like think in which you need to configure your sound for the creative card.
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  3. #3
    Just Joined!
    Join Date
    Nov 2005
    Posts
    4
    The same thing happened to me, except it installed my motherboard twice. Just go to the Sound Mixer, and choose the PCI card, that should work for you.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Newbie
    Join Date
    Nov 2005
    Location
    Philippines
    Posts
    198
    just disable your built in card in bios..
    P4 1.8, 1G DDR ram, 64mb GF2 MX400, 80G WD and 40G Maxtor, ECS mobo. Playing XP,Slack 12.0 and Vector Linux 5.8 GOLD, STD 6.0 Zenwalk 4.6.1, OpenBSD 3.9

  6. #5
    Linux Newbie
    Join Date
    Mar 2005
    Location
    Minneapolis, MN
    Posts
    112
    I had this same issue when I installed this particular Gentoo system. The best solution is to take the support for your AC'97 out of the kernel and compile the kernel again. Then you won't have any troubles, not to mention you will use less resources.
    --Dachnaz [Fuzzy Llama]

  7. #6
    Linux User
    Join Date
    May 2005
    Posts
    473
    press delete or f1 or w.e to get into your bios and find the option to disable onboard sound

  8. #7
    Linux Newbie
    Join Date
    Oct 2005
    Posts
    106

    2 sound cards

    After you have disabled the onboard sound in the bios. You may have to
    delete that soundcard in linux. It shouldn't be detected again. I don't know
    how to do this in your distribution.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •