Find the answer to your Linux question:
Results 1 to 10 of 10
Hi folks, FC2 I have CD-R purchased on the market which marked speed=52x. The speed of my Samsung writer is 40x-12x-40x. However on burning it only indicated in the range ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,787

    Burning speed


    Hi folks,

    FC2

    I have CD-R purchased on the market which marked speed=52x. The speed of my Samsung writer is 40x-12x-40x. However on burning it only indicated in the range of 20x-30x varying from disc to disc, I used following commands to burn;

    # mkisofs -J -joliet-long -o cdimage.raw /path/to/files
    # cdrecord -v -eject cdimage.rw

    The cdimage created has no problem without any warning, also checked by mounting it as loop. Whether I did some thing wrong? OR the speed on the discs was over-marked. The discs were manufactures by the brand-name of multi-nation companies. I found this problem on many occasions.

    Burning CD-RW has no problem of the same kind. The burning speed was the same as marked on the CD-RW disc up to 12x allowed by my writer.

    Please advise. TIA

    BR
    satimis

  2. #2
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211

    DMA

    Maybe that's a little trivial, but have you made sure DMA is enable on that drive?

    If not, enable it with "hdparm".

    Of course, it is always possible that the media you bought isn't performing well with your drive specificaly... (had that problem in the past)
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  3. #3
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    It has been my experience that a higher burn speed seems to cause problems more so than with disks burned at a lower speed. I never burn any cd any higher than 14x, and more often 10x. If you burned at 12x, that is certainly a slow enough speed to insure a good burn. Often CDR's you buy will just be crap and for no known reason will not work. This could be the case. I'd try again, only drop down to 8x. If you still don't get a usable cd, then my guess would be that your file is corrupted.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  4. #4
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,787

    Re: DMA

    Hi antidrugue,

    Tks for your advice.

    Maybe that's a little trivial, but have you made sure DMA is enable on that drive?
    Performed follows;

    # /sbin/hdparm -i /dev/hdc
    Code:
    /dev/hdc:
    
     Model=SAMSUNG CD-R/RW SW-240B, FwRev=R403, SerialNo=
     Config=&#123; Fixed Removeable DTR<=5Mbs DTR>10Mbs nonMagnetic &#125;
     RawCHS=0/0/0, TrkSize=0, SectSize=0, ECCbytes=0
     BuffType=unknown, BuffSize=0kB, MaxMultSect=0
     &#40;maybe&#41;&#58; CurCHS=0/0/0, CurSects=0, LBA=yes, LBAsects=0
     IORDY=on/off, tPIO=&#123;min&#58;120,w/IORDY&#58;120&#125;, tDMA=&#123;min&#58;120,rec&#58;120&#125;
     PIO modes&#58;  pio0 pio1 pio2 pio3 pio4
     DMA modes&#58;  sdma0 sdma1 sdma2 mdma0 mdma1 *mdma2
     AdvancedPM=no
     Drive conforms to&#58; ATA/ATAPI-5 T13 1321D revision 3&#58;
    
     * signifies the current active mode
    Is DMA=on OR =off ???

    Whether to run follow to enable DMA???
    Code:
    # /sbin/hdparm -d1 /dev/hdc
    OR
    Code:
    # /sbin/hdparm -d 1 /dev/hdc
    with a space.

    Is it "d0"/"d 0" = disable/off DMA

    TIA

    B.R.
    satimis

  5. #5
    oz
    oz is offline
    forum.guy
    Join Date
    May 2004
    Location
    arch linux
    Posts
    18,733
    I agree with Dapper Dan - it's better to use a slower speed (8x to 12x) if you are serious about your burns because most of the blank disks you buy at electronics retailers are pretty much pure crap even though they carry the 52x sticker.

  6. #6
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,787
    Hi Dapper Dan,

    I left the Writer to select burning speed automatically. The CD-R burned has no problem. I read each of the CD-R after burning. Off course I won't check all of them thoroughly only brief-checking.

    My question is would it be worth paying more for high speed CD-R if they can't achieve the burning speed as assured on the discs.

    BR
    satimis

  7. #7
    Trusted Penguin Dapper Dan's Avatar
    Join Date
    Oct 2004
    Location
    The Sovereign State of South Carolina
    Posts
    4,630
    All in all I think just getting quality disks are imortant if you need the assurance of a good burn. I usually buy the cheapest I can find since most are used for checking out new live cd's and distros. If I get a bad disk, I just throw it away and burn a new one. You should have the option of burning at a lower speed in your burner.
    Linux Mint + IceWM Registered: #371367 New Members: click here

  8. #8
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    You should get something like that with hdparm:

    Code:
    sudo hdparm /dev/hdc
    
    /dev/hda&#58;
     IO_support   =  0 &#40;default 16-bit&#41;
     unmaskirq    =  0 &#40;off&#41;
     using_dma    =  1 &#40;on&#41;
     keepsettings =  0 &#40;off&#41;
     readonly     =  0 &#40;off&#41;
     readahead    = 256 &#40;on&#41;
     HDIO_GETGEO failed&#58; Invalid argument
    If not, you just do :
    Code:
    hdparm -d1 /dev/hdc
    If that doesn't work, it means that you should change the order of which modules are getting loaded at startup. We'll not go there for now.

    To get it at startup, you have to edit the file /etc/hdparm.conf.
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

  9. #9
    Linux Guru
    Join Date
    Sep 2004
    Posts
    1,787
    Hi antidrugue,

    FC3

    You should get something like that with hdparm:
    Code:
    sudo hdparm /dev/hdc
    # sudo hdparm /dev/hdc
    Code:
    /dev/hdc&#58;
     HDIO_GET_MULTCOUNT failed&#58; Invalid argument
     IO_support   =  1 &#40;32-bit&#41;
     unmaskirq    =  1 &#40;on&#41;
     using_dma    =  1 &#40;on&#41;
     keepsettings =  0 &#40;off&#41;
     readonly     =  0 &#40;off&#41;
     readahead    = 256 &#40;on&#41;
     HDIO_GETGEO failed&#58; Invalid argument
    I suppose DMA is on. If I'm wrong please correct me. Tks.

    What is " HDIO_GET_MULTCOUNT failed: Invalid argument"?

    If that doesn't work, it means that you should change the order of which modules are getting loaded at startup
    Whether you meant to recompile the kernel?

    To get it at startup, you have to edit the file /etc/hdparm.conf.
    The config file does not exit,

    # find / -name hdparm.conf
    (No printout)
    Could not find it.

    BR
    satimis

  10. #10
    Linux Guru antidrugue's Avatar
    Join Date
    Oct 2005
    Location
    Montreal, Canada
    Posts
    3,211
    Yop yop, it's on, it's on.

    Anyway, I should have known better. With DMA off you don't even get the kind of speed you have right now.

    So don't bother going in that direction.

    Just for the record:
    Whether you meant to recompile the kernel?
    Sometimes, when hdparm doesn't work, it's not necessary to recompile the kernel, you can just change the order of the modules in /etc/modules, so that you have
    Code:
    piix
    ide-core
    ABOVE

    Code:
    ide-cd
    ide-disk
    ide-generic
    But, as I said, don't do that, the problem, if any, is not there.

    Have fun with Google.

    P.S. Concerning
    What is " HDIO_GET_MULTCOUNT failed: Invalid argument"?
    I'm pretty it is linked to the line
    Code:
    IO_support   =  1 &#40;32-bit&#41;
    IO_support can be 0 (disable), 1 (enable) or 3 (enable_special).

    Code:
    man hdparm
    For more info.
    "To express yourself in freedom, you must die to everything of yesterday. From the 'old', you derive security; from the 'new', you gain the flow."

    -Bruce Lee

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •