Find the answer to your Linux question:
Results 1 to 6 of 6
Hi, I am a new Linux user who is having trouble configuring an ATI Mobility Radeon 7500 (LW) graphics card in my laptop. After a couple of searches on Google ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2005
    Posts
    3

    ATI Mobility Radeon 7500


    Hi, I am a new Linux user who is having trouble configuring an ATI Mobility Radeon 7500 (LW) graphics card in my laptop. After a couple of searches on Google and the likes, I got the information that ATI does not provide oficial drivers for this card, and that suposedly there are open source drivers out there. I was wondering if anyone could help with the configuration of these, since the only info i got on it was complex technical configurations who lost me to the point of not even finding a download link to these drivers.

    The operative system is SuSE 9.3. At boot, when it gets to the graphical part the whole screen goes randomly blurred and I cannot do anything with it.

    Any help would be great, thanks in advance.

  2. #2
    Linux Enthusiast deltaflyer's Avatar
    Join Date
    May 2005
    Posts
    577
    if you don't require 3d,just boot to runlevel 3 & run sax2. that should get your screen up & running. to get to runlevel 3 in boot options at start press 1 then enter or choose failsafe mode, then type root press enter then type root password & enter. now type sax2 & press enter. once sax has started follow the screens to set up your screen

    andy
    SLOMO: acer extensa 5235 2.2ghz,2gb ram 160gb hdd wireless
    SPEEDY: homebrew desktop,Amd x2 dualcore,2gb ram,500gb +1tb( 2x500gb) hdd suse 11.3,32mb fibreline
    registered linux user #401845

  3. #3
    Just Joined!
    Join Date
    Nov 2005
    Posts
    3
    3rd is dispensable. I've been messing with Sax2 previously, particularly when i installed the operative system and the screen looked fine except that i couldn't pick my graphics card from the list, and any similar models did not work. Now when running Sax2 with runlevel 3, I get the blurred screen straight away, and it keeps going weird like that when I exit to the command line by using ctrl+alt+backspace.

    Using YaST to set it up doesn't work neither. When i switch from text to graphical, then select "change" it goes to that weird screen. And when coming back by the same ctrl+alt+backspace method, the screen with YaST remains weird. So basically it's the same thing. It's strange the way this has developed, because previously when coming back the screen just flashed ocasionally, and before that it behaved normally. But I never got the graphical environment to work.

    I've been having also a couple errors regarding my windows partitions and the swap partition when booting, I wonder if these have any relation?

    Another strange thing I've found out is that I appear to have applications installed both related with GNOME and with KDE. I'll probably install Linux all over again and try not to mess at all with the list of software, but I doubt it'll solve anything since this is already the 2nd install, the first time I got the same graphic card problems.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Enthusiast deltaflyer's Avatar
    Join Date
    May 2005
    Posts
    577
    have you tried using the vesa driver? that should give you basic 2d.failing that, try following the guide in this link

    http://www.rage3d.com/content/articles/atilinuxhowto/
    SLOMO: acer extensa 5235 2.2ghz,2gb ram 160gb hdd wireless
    SPEEDY: homebrew desktop,Amd x2 dualcore,2gb ram,500gb +1tb( 2x500gb) hdd suse 11.3,32mb fibreline
    registered linux user #401845

  6. #5
    Just Joined!
    Join Date
    Nov 2005
    Posts
    3
    With a new install, that Vesa driver worked. I guess it probably isn't the most adequate driver (?), but it's doing fine. Thanks a lot for the tip.

  7. #6
    Linux User
    Join Date
    Jan 2004
    Posts
    357
    ATI (and Nvidia) does have drivers for most of thier cards, but it doesn't look like ATI lists the 7500. Is it brand new or a little older? You typically just need to wait for the newest cards to get a driver. Windows first then Linux is ATI's policy right now.

    Here's some info from ATI on Linux supported cards.
    http://www2.ati.com/drivers/linux/linux_8.16.20.html

    But have a look here for some notebook drivers.
    https://support.ati.com/ics/support/...ge&folderID=27

    Or for all the ATI cards look here
    https://support.ati.com/ics/support/...ge&folderID=27

    Or if you have the Packman repo enabled in Yast search for 'fglrx' and give that a try.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •