Find the answer to your Linux question:
Results 1 to 9 of 9
Hey everyone, I seem to be having some odd problems with my CDROM and permissions. When ever I want to use it to rip/play music (I haven't really tried data ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Guru bryansmith's Avatar
    Join Date
    Nov 2004
    Location
    /Ontario/Canada
    Posts
    2,619

    CDROM Permissions


    Hey everyone,

    I seem to be having some odd problems with my CDROM and permissions. When ever I want to use it to rip/play music (I haven't really tried data cd's yet), I have to do a quick 'chmod 666 /dev/cdroms/cdrom0' first and then I can use it properly. If I don't, it is as if there is no disc present or there is a disc error. My question then is how do I have it so I don't have to chmod my CDROM every time I turn on my laptop? I know it can be done because I have never had this problem with any other distros.

    In case you need it, here is the contents of my /etc/fstab:
    Code:
    #
    # /etc/fstab: static file system information
    #
    # <file system>        <dir>         <type>    <options>          <dump> <pass>
    none                   /dev/pts      devpts    defaults            0      0
    none                   /dev/shm      tmpfs     defaults            0      0
    tmpfs                  /tmp          tmpfs     defaults            0      0
    usbfs                  /proc/bus/usb usbfs  defaults            0      0
    
    /dev/cdroms/cdrom0     /mnt/cd   iso9660   user,noauto,unhide   0      0
    /dev/cdroms/cdrom0     /mnt/dvd  udf       user,noauto,unhide   0      0
    /dev/floppy/0          /mnt/fl   vfat      user,noauto             0      0
    
    /dev/discs/disc0/part2 swap swap defaults 0 0
    /dev/discs/disc0/part3 / reiserfs defaults 0 0
    /dev/discs/disc0/part1 /windows/C ntfs    nls=utf8,umask=0222 0       0
    /dev/discs/disc0/part5 /windows/E vfat    iocharset=utf8,umask=000   0       0
    Thanks in advance,
    Bryan
    Looking for a distro? Look here.
    "There can be no doubt that all our knowledge begins with experience." - Immanuel Kant (Critique of Pure Reason)
    Queen's University - Arts and Science 2008 (Sociology)
    Registered Linux User #386147.

  2. #2
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    this may sound a bit obvious, but, have you added yourself to the cdrom group?
    Life is complex, it has a real part and an imaginary part.

  3. #3
    Linux Guru bryansmith's Avatar
    Join Date
    Nov 2004
    Location
    /Ontario/Canada
    Posts
    2,619
    I wish it was that easy. Unfortunately, there is no cdrom group. Should I try creating one and adding myself to it?

    Bryan
    Looking for a distro? Look here.
    "There can be no doubt that all our knowledge begins with experience." - Immanuel Kant (Critique of Pure Reason)
    Queen's University - Arts and Science 2008 (Sociology)
    Registered Linux User #386147.

  4. #4
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    hmm, no cdrom group? I"d guess you could try creating the group, but I have no idea how to tell the system that that particular group can access the cdroms.
    Life is complex, it has a real part and an imaginary part.

  5. #5
    Linux Guru bryansmith's Avatar
    Join Date
    Nov 2004
    Location
    /Ontario/Canada
    Posts
    2,619
    As we had both guessed, this didn't work. Any more ideas?

    Bryan
    Looking for a distro? Look here.
    "There can be no doubt that all our knowledge begins with experience." - Immanuel Kant (Critique of Pure Reason)
    Queen's University - Arts and Science 2008 (Sociology)
    Registered Linux User #386147.

  6. #6
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    Quote Originally Posted by bryansmith
    As we had both guessed, this didn't work. Any more ideas?

    Bryan
    Unfortunately I have no elegant ideas as to how to fix the problem. A cheap hack would be to execute chmod 666 /dev/cdroms/cdrom during bootup.
    Life is complex, it has a real part and an imaginary part.

  7. #7
    Linux Guru bryansmith's Avatar
    Join Date
    Nov 2004
    Location
    /Ontario/Canada
    Posts
    2,619
    I was thinking of that but I was wondering if there was another way.

    Thanks for the help.

    Bryan
    Looking for a distro? Look here.
    "There can be no doubt that all our knowledge begins with experience." - Immanuel Kant (Critique of Pure Reason)
    Queen's University - Arts and Science 2008 (Sociology)
    Registered Linux User #386147.

  8. #8
    Banned CodeRoot's Avatar
    Join Date
    Sep 2005
    Posts
    567

    Re: CDROM Permissions

    #
    # /etc/fstab: static file system information
    #
    # <file system> <dir> <type> <options> <dump> <pass>
    none /dev/pts devpts defaults 0 0
    none /dev/shm tmpfs defaults 0 0
    tmpfs /tmp tmpfs defaults 0 0
    usbfs /proc/bus/usb usbfs defaults 0 0

    /dev/cdroms/cdrom0 /mnt/cd iso9660 user,noauto,unhide 0 0
    /dev/cdroms/cdrom0 /mnt/dvd udf user,noauto,unhide 0 0
    /dev/floppy/0 /mnt/fl vfat user,noauto 0 0

    /dev/discs/disc0/part2 swap swap defaults 0 0
    /dev/discs/disc0/part3 / reiserfs defaults 0 0
    /dev/discs/disc0/part1 /windows/C ntfs nls=utf8,umask=0222 0 0
    /dev/discs/disc0/part5 /windows/E vfat iocharset=utf8,umask=000 0 0
    This doesn't look right...

  9. #9
    Linux Guru bryansmith's Avatar
    Join Date
    Nov 2004
    Location
    /Ontario/Canada
    Posts
    2,619
    It's devfs, not udev. The weird thing though is that my grub config file has to be udev (since I upgraded from linux 2.6.10 to 2.6.13.4) but my /etc/fstab is devfs and works fine. I could try changing the cdrom to udev. Thanks for the idea.

    Bryan
    Looking for a distro? Look here.
    "There can be no doubt that all our knowledge begins with experience." - Immanuel Kant (Critique of Pure Reason)
    Queen's University - Arts and Science 2008 (Sociology)
    Registered Linux User #386147.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •