I stopped using ati's drivers a while ago because when I'd maximize an application, it would maximize across both windows for some stupid reason. My current setup has two monitors with their own display so I can have apps on one and the other, and drag apps between them. Here is my current xorg.conf. did ati fix the maximize problem, and if so, what need I change in this config file to change to fglrx correctly after installing it?


Section "Module"
Load "ddc" #Automatic Information from LCD
Load "dbe" # Double Buffer Extension
SubSection "extmod"
Option "omit xfree86-dga"
EndSubSection
Load "glx" #GLX
Load "freetype" # font
Load "bitmap" # font
Load "type1" # font
EndSection

Section "Files"
RgbPath "/usr/X11R6/lib/X11/rgb"
ModulePath "/usr/X11R6/lib/modules"
FontPath "unix/:7100"
EndSection

Section "ServerFlags"
EndSection

Section "InputDevice"
Identifier "Keyboard"
Driver "kbd"
Option "XkbModel" "pc105" # Hey, this doesn't make sense. Check it.
Option "XkbLayout" "us" # or maybe this?
EndSection

Section "InputDevice"
Identifier "Mouse"
Driver "mouse"
Option "Protocol" "ExplorerPS/2" # Better than ImPS/2
Option "ZAxisMapping" "4 5" # Wheel
Option "Device" "/dev/input/mice"
EndSection

Section "Monitor"
Identifier "CRT1"
HorizSync 30 - 86
VertRefresh 50 - 150
Option "DPMS"
EndSection

Section "Device"
Identifier "RADEON"
Driver "radeon"
Option "AGPMode" "4" # 4x
Option "BusType" "AGP" # Bus
Option "EnablePageFlip" "on" # Gives some performance boost.
Option "MonitorLayout" "CRT, CRT"
Option "MergedFB" "true"
Option "CRT2HSync" "30-61"
Option "CRT2VRefresh" "50-76"
Option "CRT2Position" "RightOf"
Option "MetaModes" "1600x1200-1024x768"
BusID "PCI:1:0:0"
Screen 0
EndSection

Section "Screen"
Identifier "Screen0"
Device "RADEON"
Monitor "CRT1"
DefaultDepth 24
Subsection "Display"
Depth 24
Modes "1600x1200"
Viewport 2560 1024
EndSubsection
EndSection

Section "ServerLayout"
Identifier "Server Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse" "CorePointer"
InputDevice "Keyboard" "CoreKeyboard"
EndSection