Find the answer to your Linux question:
Results 1 to 7 of 7
hello, i just got my christmas gift from myself in the mail today; an iRiver H10 20GB MP3 player. I connected the device and got this message from dmesg. usb ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2005
    Location
    look out your window
    Posts
    72

    iRiver H10 problems


    hello, i just got my christmas gift from myself in the mail today; an iRiver H10 20GB MP3 player.
    I connected the device and got this message from dmesg.

    usb 1-3: new high speed USB device using ehci_hcd and address 6

    I googled and found this:
    http://gentoo-wiki.com/HOWTO_iRiver
    that tells me to have these things installed in kernel config:
    Device Drivers --->
    USB support --->
    <*> EHCI HCD (USB 2.0) support
    <*> OHCI HCD support
    <*> UHCI HCD (most Intel and VIA) support
    <*> USB Mass Storage support

    I made sure i had those, recompiled, and copied the bzImage to /boot/kernel-2.6.13-gentoo-r3...my kernel

    then i did:
    dmesg | grep scsi
    but it returned nothing
    i did
    dmesg | less
    and looked for anything concerning the device, but i got nothing but

    usb 1-3: new high speed USB device using ehci_hcd and address 6

    I cant seem to get it working, and it SHOULD work because its just a USB mass storage drive, (VFAT fs type)

    any help please post
    tuxxman

  2. #2
    Linux Guru Cabhan's Avatar
    Join Date
    Jan 2005
    Location
    Seattle, WA, USA
    Posts
    3,252
    My iRiver is detected under /dev/sda1. You might check for such a device on your system?

    And congrats on choosing the iRiver, by the way. I've not used the H10, but I have the H320, and I love it.

  3. #3
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790
    Quote Originally Posted by Cabhan
    My iRiver is detected under /dev/sda1. You might check for such a device on your system?

    And congrats on choosing the iRiver, by the way. I've not used the H10, but I have the H320, and I love it.
    hehe, i forked out the little extra to get me my H340! It's fantastic! Lovin it! And the sound quality is immense! I get no crap sounds from it, even on full volume, all the sound is pure and crisp, think the Sennheiser earbuds do it justice!

    Cabhan, another point, i have mine show up as /dev/iriver and the partition /dev/iriver1 Isn't udev great!

    When i get my camera on Sunday, that'll b goin in /dev/digicam
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jul 2005
    Location
    look out your window
    Posts
    72
    dmesg doesnt see the device anywhere...i pasted the output:

    usb 1-3: new high speed USB device using ehci_hcd and address 6

    is all it outputs when i plug it in, nothing more.
    I am at my moms house for the week and i prolly wont be at my dads until after christmas break (the 27th...maybe?) and my problems are on my computer at my dads.
    the player works great on windows so its not the player / port.

  6. #5
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790
    Did u try installinghotplug and coldplug? iirc now, on gentoo, coldplug provides hotplug now... check the manual, but if u dont have then, then it wont work if u plug it in hot
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

  7. #6
    Just Joined!
    Join Date
    Nov 2006
    Posts
    1

    iriver problems help me! somebody.

    Hi all I have the iriver h10 and overall its great ,got a great sound ,ive used plenty and this one is for me the simplest BUT can i find it on my computer NO.the usb ports all work.but when i plug it in the computer doesent even see it...it used to when i had windows 98.but now i have win xp and it suposed to recognise the blooming thing.in windows media player 11.I click on synch but nothing happens .all i want to do is delete my music from the h10 and put a fresh list of music and pictures on.youde think it was easy ! PLEASE CAN ANYONE HELP ME .and explain in laymans terms would be great being as ive been at it for at least 1 1/2 years now.

  8. #7
    Just Joined!
    Join Date
    May 2008
    Posts
    1
    Quote Originally Posted by jesrian View Post
    all i want to do is delete my music from the h10 and put a fresh list of music and pictures on.youde think it was easy ! PLEASE CAN ANYONE HELP ME .and explain in laymans terms would be great being as ive been at it for at least 1 1/2 years now.
    I've been having the same problems but cant seem to figure it out. I dont have the original software so I dont know if I need that in order to complete this trimultuous task however I'm very irritated and am on the verge of going out to get an IPOD like my girlfriend is tellin me to. If someone can help I would appreciate it. If not, Apple will continue it's world conquering mission.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •