Find the answer to your Linux question:
Results 1 to 5 of 5
I am fairly new to Linux ... I am running Debian Sarge, and am not getting sound on one of my machines (an old PII 233Mhz 192MB Dell). I tryed ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2005
    Posts
    13

    Sound card problems


    I am fairly new to Linux ... I am running Debian Sarge, and am not getting sound
    on one of my machines (an old PII 233Mhz 192MB Dell). I tryed disabling the
    motherboard sound, and put in a Sound Blaster ISA PNP card... still no luck.
    I am not sure what if any of this is relevent ... (perhaps someone could tell me what to look for?) but the syslog shows
    isapnp: scanninig fo pnp cards...
    pnp: SB audio device quirk - increasing port range.
    isapnp: Card Creative ViBRA16C pnp
    pciehp:acpi_pciehprm: get_device pci root hid fail=0x1001
    shpchp:acpi_shpchprm: get_device pci root hid fail=0x1001
    pnp: Device 01:01.01 activated.
    gameport:ns558 pnp at pnp 01:01.01 io 200 size 8 speed 693khz

    I also noticed there is no device /dev/dsp

    Any suggestions (I am even willing to get a new sound card, if I must)?
    The motherboard supports both PCI and ISA bus.

  2. #2
    Just Joined!
    Join Date
    Dec 2005
    Posts
    13
    I have been trying to figure this out ... and this is what I have found out so far ...

    With the original sound card there was a /dev/dspW device, which after a bit of
    looking around is a 16bit sound card interface (unfortunately there was no 8 bit
    interface, which is what most software uses, hence my original problem).
    That interface went away when I disabled it,
    but the software is appearently still looking for the old soundcard,
    and ignoring the "new" soundcard.

    So the question becomes ...
    Can I get my Debian Sarge Linux to recognize that the old soundcard is gone,
    and the new one exists, or must I reinstall Linux?

    Thanks,
    Steven.

  3. #3
    Just Joined!
    Join Date
    Dec 2005
    Posts
    13

    Backed off to 2.4 kernal

    Reinstalled linux sarge with 2.6 kernal ... no luck at all .... still no /dev/dsp devices.
    Reinstalled Debian Sarge (again) this time with the 2.4 kernal ... still no sound,
    but have lots of /dev/dsp and /dev/audio devices.
    Even though /dev/dsp shows up with the ls command, esd claims
    " /dev/dsp: No such device"
    anyone know what I should try (or look at) next???
    Thanks,
    Steven.

  4. #4
    Just Joined!
    Join Date
    Dec 2005
    Posts
    13
    I ran ALSACONF and sound works ... until I reboot.
    I installed alsa-base alsa-utils and alsa-modules... ran alsaconf, then sound worked
    (mostly ... the parts that use alsa anyway) on Debian Sarge (linux 2.4).
    So I went back and installed Debian Sarge (linux 2.6), then alsa-base and alsa-utils.
    I ran alsaconf and sound works very well indeed ... until I shutdown ... so I have
    to run alsaconf everytime I boot.
    Does anyone know how to make the changes permanent.
    Thanks,
    Steven.

  5. #5
    Just Joined!
    Join Date
    Dec 2005
    Posts
    13
    I have sound!!! I added my sound driver snd-????,
    where ???? was the sound driver selected by ALSACONF,
    to /etc/modules

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •