Find the answer to your Linux question:
Results 1 to 7 of 7
Hi all, first post here, having a bit of trouble that I'm having a hard time tracking down. I have a Hewlett Packard 5740 connected to a dual boot XP/Ubuntu ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2005
    Posts
    3

    CUPS - HP 5740: XP to Ubuntu Printing Comes Out Reversed


    Hi all, first post here, having a bit of trouble that I'm having a hard time tracking down.

    I have a Hewlett Packard 5740 connected to a dual boot XP/Ubuntu 5.10 CPU which is shared via CUPS in Ubuntu. It prints fine from that system whether it's in Ubuntu or XP. Printing over the network from Ubuntu works fine. However, printing from a remote XP machine over the network causes the print job to come out as a mirror image, with all the characters aligned on the right side of the page, facing the wrong way.

    Printing from a remote XP machine to the printer when the printer machine is booted into XP works fine as well. It's just printing from XP over the network to Ubuntu.

    I've tried Googling, but any results I get for "backwards printing CUPS" or "reverse printing CUPS" or anything of the sort comes up with no results relevant to my problem.

    If I need to post any information/config files, please let me know, and I will provide it.

    Thanks,
    Phil

  2. #2
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    Are you trying to print Office documents or does this happen for things typed in notepad or when printing webpages?

    If it is for office documents, edit these files as root:

    1. /etc/cups/mime.convs
    towards the end, there is a line like
    Code:
    # application/octet-stream        application/vnd.cups-raw        0
    remove the #

    2. /etc/cups/mime.types
    towards the end, there is a line like:
    Code:
    # application/octet-stream
    remove the #

    save the files, restart cups then try printing.

    If that is not the case, then perhaps you haven't installed the correct driver for the printer or something like that.
    Life is complex, it has a real part and an imaginary part.

  3. #3
    Just Joined!
    Join Date
    Dec 2005
    Posts
    3
    No joy. Thanks for the idea though.

    Same thing... text still comes out not only right to left, but the characters are reversed as well.

    I'm unsure if it would be a driver issue. I've installed the latest drivers from HP's website... if it were a driver problem, wouldn't I have the same problem printing from XP to XP? The printer is hooked up to a dual boot PC... it's only printing XP to Ubuntu that has a problem... XP to XP works fine.

    The odd thing is I've found NOTHING on this issue searching Google. I can't believe I'm the only one ever to have it. LOL

    Thanks though... any further help would be greatly appreciated. If worse comes to worse I'll just hook the printer up to my wife's XP box.

    Phil

  4. #4
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    If XP-ubuntu has a problem, try using the Adobe Postscript drivers for windows (link). Simply download the file to your XP machine, launch it and point it to the printer which is connected to the ubuntu machine. It will create drivers under \system32\spool (I think) then install the printer by telling it to get the drivers from \system32\spool.
    Life is complex, it has a real part and an imaginary part.

  5. #5
    Just Joined!
    Join Date
    Dec 2005
    Posts
    3
    Thanks, I'll give it a shot as soon as I can get my XP box booting again... friggin' system won't POST now. Don't ya love computers at times?

    phil

  6. #6
    Just Joined!
    Join Date
    Jan 2006
    Posts
    1
    Hi Phil & All,

    I've been trying to fix the same problem for weeks now... I'm really frustrated.
    I've an HP Deskjet 6540 connected to Fedora Core 4. The printer is shared amongst Linux and Win XP PCs. Printing from other Linux machines is not a problem. But Win XP will print only mirror image even if I stand on my head while printing...

    Tried to install the Adobe PS drivers as recommended by AlexK, but the PPD file has a very limited HP printers in it, so no luck.

    The only solution so far: print through samba. Seriously. It's working fine!

    If anybody else has a better idea please let me know...I gave up...

  7. #7
    Just Joined!
    Join Date
    Apr 2006
    Posts
    1

    Same problem with HP DJ3745, solved

    Hi,

    I got the same problem with my PH Deskjet 3745 and solved.

    I post the solution on this forum:

    http://www.ubuntuforums.org/showthre...721#post966721

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •