Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
i have been getting this prob since the moment i installed linux on this com... i'll run you through it.. i'm trying to install my sound card on linux i ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie
    Join Date
    Jun 2003
    Location
    55 (degrees) north 7 west
    Posts
    126

    Sound problems, help anyone?


    i have been getting this prob since the moment i installed linux on this com...
    i'll run you through it.. i'm trying to install my sound card on linux i am using the yast2 control canter thing that is on suse 8.2.. i have 2 sound cards.. an onboard nvidia one (detected and running but is no good to me) and a monster sound mx400 (diamond techonoligies(old i know))..
    i try to install the diamond monster sound and on the last page it comes up with
    An error occured during the installition of : monster sound mx 400.
    The kernel module snd-es1968 for sound support could not be loaded. this can be caused by incorrect module parameters, including invalid IO or IRQ parameters
    i have no idea what this is on about ^_^.
    can anyone help?
    thanks in advance.
    P.s if you need more information, my computer is haunted ^_^
    Thanks v much

    \"Anything bigger than my ego i want it caught and killed\"- Zaphod Beeblebrox

    Multi boot:
    Win xp home, SuSE 8.2 and Slackware 9.1

  2. #2
    Linux User
    Join Date
    Jun 2003
    Location
    Calgary, AB CANADA
    Posts
    496
    So you have the onboard one fully operational, but want to use the monster one instead?

    My guess is that you have to have the onboard one disabled (either thru bios or jumpers) before the system will recognize the plugged in one.

    I could be wrong, but this is how I've always done it...
    \"Everything should be made as simple as possible, but not simpler.\"
    Albert Einstein

  3. #3
    Linux Newbie
    Join Date
    Jun 2003
    Location
    55 (degrees) north 7 west
    Posts
    126
    nope it didn't work, its enabled altogether.
    (it works in win)
    thanks
    Thanks v much

    \"Anything bigger than my ego i want it caught and killed\"- Zaphod Beeblebrox

    Multi boot:
    Win xp home, SuSE 8.2 and Slackware 9.1

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User
    Join Date
    Nov 2002
    Posts
    420
    An error occured during the installition of : monster sound mx 400.
    The kernel module snd-es1968 for sound support could not be loaded. this can be caused by incorrect module parameters, including invalid IO or IRQ parameters
    This is because another sound driver has allready grabbed the sound... You need to recompile the kernel and turn off all sound except for the one that you will be using. Then reboot, it will give ya the same error again, at least it did on mine....

    Do a lsmod and see what sound drivers are running. I assume that you are using the nvaudio one?? rmmod it, and then insmod "the one you want".

    You will need to find what is loading the nvaudio one at boot time, and disable it....

    See what that does

    I recently went through this myself, and got it to work. Let me know if ya need anything..

  6. #5
    Linux Newbie
    Join Date
    Jun 2003
    Location
    55 (degrees) north 7 west
    Posts
    126
    right i get cha'
    ill disable it and reinstall and all and hopefully it will work if it doesn't hopefuly i get the new kernel. just one thing the sound doesn't work at all just incase you didn't get that when i pluginto the onboard sound (nvidia) nothing aswell so....
    but thanks v much
    Thanks v much

    \"Anything bigger than my ego i want it caught and killed\"- Zaphod Beeblebrox

    Multi boot:
    Win xp home, SuSE 8.2 and Slackware 9.1

  7. #6
    Linux Engineer
    Join Date
    Sep 2003
    Location
    Knoxhell, TN
    Posts
    1,078
    i know this sounds like a smartass question, but did you unmute the mixers?
    Their code will be beautiful, even if their desks are buried in 3 feet of crap. - esr

  8. #7
    Linux Newbie
    Join Date
    Jun 2003
    Location
    55 (degrees) north 7 west
    Posts
    126
    yeah i have and i know it can always be a stupid thing like that.
    but i uninstalled the nvidia one then tried to install the monster but no luck it said the same thing (i did unload all the sound files (if thats the right thing to say)) then i reinstalled the nvidia and i ran the sound test and the sound only came up in one ear (i had a set of headphones on) and it stoped half way through the test.. when i went to shut down same thing the sound was in one ear and jumpy... i don't get any of this in xp at all everything works grand so the cards are fine.
    spooky no?

    thanks v much
    Thanks v much

    \"Anything bigger than my ego i want it caught and killed\"- Zaphod Beeblebrox

    Multi boot:
    Win xp home, SuSE 8.2 and Slackware 9.1

  9. #8
    Linux Engineer
    Join Date
    Sep 2003
    Location
    Knoxhell, TN
    Posts
    1,078
    are you trying to use ALSA or OSS? if it's ALSA and kernel<2.6, then you have to disable *all* sound cards in your kernel and compile sound card support as a module.. then rebuild your kernel.. after the kernel is built you have to build the ALSA drivers for your card.. then set up an rc script to enable it at *boot* before runlevel 3 or 5...

    hth
    Their code will be beautiful, even if their desks are buried in 3 feet of crap. - esr

  10. #9
    Linux Newbie
    Join Date
    Jun 2003
    Location
    55 (degrees) north 7 west
    Posts
    126
    crap.

    ok heres the scoop... got the kernel (2.6) so ill disable all the sound and un load it off of the kernel (i'm still no sure if thats the rite thing to say but stillllll...) then compile and install the new kernel then make up the sound and ..... that should work rite?
    thanks
    Thanks v much

    \"Anything bigger than my ego i want it caught and killed\"- Zaphod Beeblebrox

    Multi boot:
    Win xp home, SuSE 8.2 and Slackware 9.1

  11. #10
    Linux Engineer
    Join Date
    Sep 2003
    Location
    Knoxhell, TN
    Posts
    1,078
    not to sure on that.. the instructions i follow are for 2.4.x... haven't installed 2.6 yet.. you can try the old method, but the sound drivers in 2.6 are supposed to be ALSA, so it shouldn't be too hard to get working.. just make sure you have alsa-utils installed.. and perhaps you should check the alsa homepage (not sure what it is atm) to see if they have some docs that are a little more helpful than my ideas...
    Their code will be beautiful, even if their desks are buried in 3 feet of crap. - esr

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •