I have been trying to get either of my sound cards to work. Soundblaster 5.1 and n_vidia onboard. I DL and tried to instlal oss mods but all but one time it fails. One time it worked and i am not sure why. But then mysteriously the mods dissappeared for no reason. No reboot, not even a log out, its like they were there one second and next time i tried to play music they werent. Here is what happened evertime i try to install 0ss....

Checking for any previously installed sound drivers...
*** Sound driver is already running - trying to unload it ***

You appear to have the the kernel level sound driver installed as a loadable
module. Unload it by executing rmmod sound and try installing OSS/Linux again.

If this error repeats again you probably have the sound driver being loaded
automagically by the kerneld daemon. In this case you should remove all sound.o
files from all subdirectories of /lib/modules in addition to executing
rmmod sound. After that you probably should reboot the system before trying to
install OSS again. Edit /etc/modules.conf and remove the 'alias sound ...'
line in case it exist and replace it by 'alias sound off'.

Also add a line containing 'alias char-major-14 off' to /etc/modules.conf.
Am I allowed to do these changes automatically for you (Y/N) ? y
Trying to disable the conflicting sound driver
/etc/modules.conf backed up to /etc/modules.conf.pre-oss
Unloading the existing sound driver
If your system freezes now, please reboot and disable the current driver manually.
audio: Device or resource busy
Failed to unload module 'audio'
soundcore: Device or resource busy
Failed to unload module 'soundcore'
[root@Homer tmp]# rmmod sound
rmmod: module sound is not loaded
[root@Homer tmp]# rmmod audio
audio: Device or resource busy
[root@Homer tmp]# rmmod sooundcore
rmmod: module sooundcore is not loaded
[root@Homer tmp]# rmmod soundcore
soundcore: Device or resource busy
I would like any guidance. I am not a total n00b but i am fairly new at linux and this is my only problem . Thank You.

PS i tried to reboot to free up the mods....but that didnt work and previous to this attempt i already got rid of sound.o from lib/modules sub-dir.